I got a Gigabyte GA-P35-DS3 motherboard.

Some time ago I noticed that Windows only showed 2GB instead of 4GB. I don't know exactly what caused it anyway.

I tried putting in each of the 4 x 1GB RAM modules one by one, and tried every slot one by one, until every stick and slot worked. However, then I tried adding one more at a time, and it kept showing 1GB, until I put in all 4, where it only showed 2 GB instead of 4 (in BIOS and windows 7 64bit).

I tried replacing the BIOS battery since I've read that low battery could cause it. It didn't help though. I also bought 4GB new RAM (yes, it's supported, I checked it), and it's still the same, it only shows 2GB (or 3GB, when I put in 4 of the new and 2 of the old).

I also did the latest BIOS update, and used default BIOS settings, but nothing of that helped. When my PC boots it shows "RAM modules used 2 and 3", when 4 sticks are in - or "0 and 1", when only 2 are in.

  • 4
    Are you using the Intel GPU and have 2GB allocated to that? – Richard Nov 11 '12 at 15:21
  • @Richard then he should not see 3GB when plugging in 6GB in total. – TheUser1024 Nov 11 '12 at 15:39
  • @Joey he said in the BIOS and in 64bit Win7, and btw. 32bit Win usually reports 3.x GB when you got 4GB or more. – TheUser1024 Nov 11 '12 at 15:40
  • If the memory is not detected in BIOS then I would strongly suspect a motherboard fault – Tog Nov 11 '12 at 20:21

Check this RAM compatibility list from Gigabyte for that MoBo and check the last column titled "Dual Channel Load (Pcs.)" if you use DDR2 1066. I am not entirely sure what it means, but it looks like it could be the max amount of such modules your MoBo can handle. For most 1GB modules it only seems to allow 2, while only the Kingston 1GB models have a "4" in there. That could at least explain the halving effect you are seeing if my other assumptions are correct. There is not such column for the modules with lower frequencies, so maybe clocking yours down to 800 might make them show up.


My first although not very helpful suggestion would be that your motherboard is faulty.

The only thing you can do before replacing your motherboard is running Memtest86+ and see if it detects your full RAM amount there.

You don't have to run the full memory test but just check if at least it detects all your RAM there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.