I've recently completed tinkering my new pc(motherboard ASUS z77 with UEFI BIOS) and unfortunately not everything works quite well.

After installing windows 7 ultimate on a single primary partition(SATA drive) I decided to allocate one more logical partition for additional needs. When I tried doing it with the manager - it said that it couldn't allocate requested size even though I certainly asked for much less than it was available.

I thought that it might have been a windows issue and proceded to installing Ubuntu 12.10 x64. When the graphical interface loaded it showed me a message stating that it can't find any other operating system on the drive. When I used custom partioning option it showed me none of my current partions(including that with windows). However, when I boot with "Try Ubuntu" feature it does find them ! I find it weird though.

Here's what the console present me with:

ubuntu@ubuntu:~$ sudo os-prober 
/dev/sda1:Windows 7 (loader):Windows:chain
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00072b98

 Device Boot      Start         End      Blocks   Id  System

/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   100020223    49906688    7  HPFS/NTFS/exFAT
/dev/sda3       100022270  1250263039   575120385    5  Extended
/dev/sda4       566669312  1250263039   341796864   83  Linux

I also tried creating partitions from disk utility which results in error: enter image description here ,

Error creating partition: helper exited with exit code 1: In part_add_partition: device_file=/dev/sda, start=51211402240, size=1923000000, type=0x83 Entering MS-DOS parser (offset=0, size=640135028736) MSDOS_MAGIC found looking at part 0 (offset 1048576, size 104857600, type 0x07) new part entry looking at part 1 (offset 105906176, size 51104448512, type 0x07) new part entry looking at part 2 (offset 51211402240, size 588923274240, type 0x05) Entering MS-DOS extended parser (offset=51211402240, size=588923274240) readfrom = 51211402240 MSDOS_MAGIC found Exiting MS-DOS extended parser looking at part 3 (offset 290134687744, size 349999988736, type 0x83) new part entry Exiting MS-DOS parser MSDOS partition table detected containing partition table scheme = 1 got it Error: Can't have overlapping partitions. ped_disk_new() failed

Here's what I get when I try to install the system

enter image description here

enter image description here

P.S. It's strange that I even can't create any more partitions neither with disk-utility nor with windows 7 native tools

  • Can you upload the images to imgur.com and link them, I will add it – HackToHell Nov 11 '12 at 16:03
  • yup, I've got something else to add. just a second – user971155 Nov 11 '12 at 16:18
  • 1
    UEFI-related problems are hitting pretty hard right now. I'm under a similar situation and there doesn't seem to be a lot of support for UEFI atm. The only program that seems to work decently with UEFI is boot-repair but even that worked partially for me. Most of these problems seems like they're only able to get fixed via a reinstall. I've been researching for the past 48 hours and that seems to be the only option for me. /rant Sorry I don't have much to add to help your problem but I just wanted to share my experience. I wish you good luck! – Tek Nov 11 '12 at 16:44
  • okay, thanks - but I want to elucidate that my windows 7 has just been installed, but there are older partitions on the drive present. So, do you think their presence might result in this behaviour and I should blank everything and reinstall ? – user971155 Nov 11 '12 at 16:54

This is NOT an EFI/UEFI issue. Your hard disk uses the Master Boot Record (MBR) partitioning system and successfully boots Windows, which means that it's booting Windows in BIOS mode. There's no EFI System Partition (ESP) on the disk, which means that it's not booting anything else in EFI mode (unless you've got a USB flash drive or something with an ESP and EFI boot loaders on it).

The really key clue is a bit from the end of what you quoted from GParted's (or was it Disk Utility's?) console message:

Error: Can't have overlapping partitions. ped_disk_new() failed

Basically, because of whatever alignment policies you selected, the partitioning tool tried to create a partition that either began before an earlier partition ended or ended after a later partition began. Libparted (upon which GParted, Disk Utility, and several other programs relies) is known to do this from time to time. There are at least three possible workarounds:

  • Manually enter partition start/end points that leave a little space between partitions. Normally 1MiB is enough.
  • Change the partition alignment options in your partitioning tool. Recent versions of GParted let you select between 1-MiB alignment, cylinder alignment, and no alignment. Normally, 1-MiB alignment is best, but if it's giving you problems and if you know you're using a non-Advanced Format disk, you can change it to something else with little risk of problems. OTOH, if you're using an Advanced Format disk, you should not try this method unless it's defaulting to something other than 1-MiB alignment.
  • Switch to another partitioning program, preferably something that's not based on libparted. For an MBR disk in Linux, this basically means fdisk. You'll then have to use a text-mode filesystem creation tool (such as mkfs) or GParted to create a filesystem in the partition you create.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.