In Fedora 17, when I want to plug my USB hard disk out, I can only unmount it. But the problem is that the hard drive won't be powered off so that I can plug it out.

In some other distros like Ubuntu there is a Safely Remove option which powers the hard drive off.

How can I fix that?

  • Does hdparm -y /dev/sdX work?
    – slhck
    Nov 11 '12 at 19:56
  • Nope sir. This command removes the drive name from nautilus menu but does not power it off.
    – Mehrdad
    Nov 11 '12 at 20:44

After a lot of web surfing I came across the solution suggested by someone in askubuntu.com. Thank you everybody. I just needed to install udisks package! To power off my hard disk I have to enter the following command in terminal after unmounting all of its partitions:

udisks --detach /dev/sdX
  • Haven't tested this (used udisks --unmount) and udisks -h doesn't list --detach for me. Fedora 19.
    – hakre
    Aug 27 '13 at 19:30
  • 2
    As of ubuntu 15.10, this seems to be udisksctl power-off -b /dev/sdb. BTW, as a response, my HDD switched off its light but still emitted noise and vibration until I physically plugged it off.
    – gluk47
    Oct 30 '15 at 23:50
  • @gluk47's comment is worked for me on ubuntu 16.04. Though my hard-drive did fully power down.
    – Totem
    Jan 16 '17 at 18:39

There is no safe removal button for the USB drive. You can eject the USB drive by clicking the small triangle which is on the side of the USB drive.

For ejecting a flash drive follow these steps:

  1. First see the USB drive by entering this command:

    fdisk -l
  2. Assuming your USB drive is /dev/sdb1, eject it with the following command:

    umount /dev/sdb1


    eject /dev/sdb1 

This will allow you to safely remove your USB drive.

  • The "little triangle" can be found under Activities > Files and by locating the USB drive on the left pane. The icon is to the right of the USB drive's label. Jun 18 '15 at 5:53


eject /dev/sdX

where X is the letter of your device.


You can find all available drive letters by using fdisk -l.

  • 1
    Could you explain how to find out what the device letter is? I would assume this can be confused quite easily.
    – slhck
    Nov 11 '12 at 18:52
  • This did not help. I also checked eject's man page in which it is written that this command does the same as umount according to the device in use.
    – Mehrdad
    Nov 11 '12 at 19:01
  • eject /media/THE_DISK should also work (if it is mounted there). @Mehrdad, don't believe too much what manuals say. They might be wron (report to bugzilla if so).
    – vonbrand
    Feb 25 '13 at 2:57
  • @Josiah please mention fdisk -l in your answer as the means to check drive letters, or any other mean you find appropriate. Apr 20 '13 at 20:22
  • If you are not root, you can still get an idea what the drive letter is, using blkid.
    – gluk47
    Jan 16 '17 at 20:25

As of Ubuntu 20.04

udisksctl power-off -b /dev/sdb turns off the LED of an external HDD.

Note: regarding eject, it apparently has multiple methods that it tries until one of them "succeeds" (use -v to see what's going on). Nothing really helped:

  • eject -v /dev/sdb tried CDROM ejection and reported success, but didn't actually do anything (no LED changes, no dmesg messages)
  • eject -v --scsi /dev/sdb (explicitly chosen method) actually succeeded in ejecting, but the drive was detected right back (as evidenced by dmesg)

Enter the following command to power off the hard drive:

hdparm -y /dev/sdx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.