I have a Dell XPS 15 which shipped with Windows 7 x64, which I recently upgraded to Windows 8. The process went surprisingly smoothly (given that this was an upgrade, not a complete re-install), and the system generally seems very stable.

However, today I noticed that several of the Windows Store apps don't work: they all behave in the same way, launching but then showing a spinning 'wait' animation indefinitely. This is affecting the standard Microsoft Mail, Store, Weather, News, Travel, Finance, Sport, Games and Music apps.

The Bing app just shows a Bing logo on a coloured background (but no wait animation).

The Calendar, Photos and SkyDrive apps open but then show a white screen.

The Maps and Camera apps work without problems.

The live tiles on the Start screen are updating correctly, for example the Mail app's tile shows a summary of new mail despite the Mail app's problems.

All of these applications were working correctly a few days ago. I'm sure I've used several without problems since the last Windows update occurred on 7th November.

Any suggestions on what might have happened and/or how to fix it would be very welcome. I don't need these Windows Store applications, but the fact that they're not working is irritating me.

  • 1
    Have you restarted since (as opposed to just putting the computer to sleep?) – Rowland Shaw Nov 12 '12 at 17:07
  • Yes, I've tried restarting several times. I've also tried disabling my (McAfee) firewall and restarting, just in case that was related. Unfortunately, no change. – David Miller Nov 12 '12 at 17:27
  • Open the Event Viewer (Search for Event Viewer on the Start Screen, it'll come up in the settings). Take a look at Windows Logs->Application – Rakib Ansary Nov 13 '12 at 4:17
  • I had a look at the application logs, but couldn't see anything that obviously indicated the source of the problem. – David Miller Nov 13 '12 at 13:56

Some troubleshooting steps which might help you:

  1. If you have Avast installed, remove it. Avast apparently is not letting apps run (as I have seen on numerous forums). Wait for version 2013 (I don't know if it has already released, in that case, install 2013 then). I see you don't have Avast as you have mentioned in the comments. Please proceed to Step 2 then

  2. If you don't have Avast, open the command prompt with elevated permissions (tip: press Windows+X and select Command Prompt (admin). Run this command sfc/scannow

  3. Generally, sfc fixes any system file errors and restarts the system. If they still don't work, you have to do a Refresh. Sadly.

  • No, using McAfee not Avast (as you spotted). I could try disabling this, but it was running when the apps were working previously. – David Miller Nov 13 '12 at 8:49
  • I will try an sfc/scannow. I'm not sure what a system refresh will do on an upgraded system - what would it refresh to? – David Miller Nov 13 '12 at 8:49
  • When did the apps stop working? – pratnala Nov 13 '12 at 9:14
  • I did a clean install but I don't know what happened and Metro stopped working. Had to do a refresh – pratnala Nov 13 '12 at 9:16
  • sfc /scannow didn't help, unfortunately (although it claimed to fix some things). Neither has uninstalling McAfee (seemed worth a try). – David Miller Nov 13 '12 at 10:15

I appear to have solved my problem (although possibly only temporarily!) using System Restore. After failing to reinstall McAfee (which I uninstalled as a test, which I believe led to a broken Windows scripting environment which broke its own installer - see my notes above) it seemed that nothing less than a System Refresh would be enough. However, a System Restore to a handy restore point from about a week ago has restored McAfee and fixed all of my broken Modern UI apps.

I have since reinstalled the drivers that were rolled back, and everything is still working. If it breaks again, I will give up and refresh (if that works on an updated Windows 7) or reinstall.

It may be unrelated, but at around the time when my Modern UI apps broke I noticed that Windows had automatically installed a Modern UI app for my HP Photosmart 5515, presumably after noticing it on the network. This hasn't reappeared yet (I'm currently connected to a different network).

So, if all else fails it may be worth trying a system restore before a refresh.

  • Yes I would agree the source of the problem was because you installed software from HP :-) – Ramhound Nov 27 '12 at 16:23
  • Frighteningly, Windows 8 installed it all on its own! :-) – David Miller Nov 28 '12 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.