I recently switched ISPs and the new one seems to do something a bit weird. It is through a dish that just gives me a ethernet cable with internet. The dish handles all the connection stuff (if I plug the cable into my laptop it just works) and handles assigning all the local IP addresses (the DHCP server in the router has to be turned to DHCP FORWARDER).

The strange part (or at least what sounds strange to me) is that the Internet cable CANNOT be plugged into the Internet port. The Internet is working!!! But the router is not correctly seeing it; So it is not logging bandwidth used, it does not show the WAN IP through the router interface, I lose a port, and it is just generally all round annoying.

Is this normal? Is there a setting I can change to fix some/all of these annoyances? Can you explain why it is like this?

Thanks for any and all help.

Technical Info: WRT54GL v1.1, with standard recommended DD-WRT installed. NOT that this should matter, except if you want to offer specific resolution answers.

Partial Solution: The default DDWTR configuration sets the WAN port to a separate vlan as the other ports. Changing this so that all ports are on a single vlan allows the use of the WAN port. This does not solve the router is not logging bandwidth use or showing my WAN ip, etc. issues.

Also, at least in DDWRT, it appeared like I am supposed to set Operating Mode to "Router". "Operating Mode: If the router is hosting your Internet connection, select Gateway mode. If another router exists on your network, select Router mode." But I do not know if this solved anything, as it was working in Gateway mode, and continues to work in Router mode.

| |
  • 2
    The "Internet cable" is actually a connection to your local network, not the Internet. It should not be connected to a WAN or Internet port. That's used to connect to a different network, not to connect to your own network. (If you're using DD-WRT, you can just configure it so that all ports are LAN ports.) – David Schwartz Nov 12 '12 at 21:34

There isn't really anything abnormal, but, it isn't really that normal either.

They are providing you with a connection that is connected to a router somewhere and they are giving you a feed from the lan side - they are expecting you to simply plug that in to a switch and share between computers without requiring a router.

(A router with DHCP disabled, and if you only use the lan ports is pretty much the same as a switch).

My guess is that if you plugged it in to the WAN port of your router, there is nothing that should stop it working - however, you will have double NAT and could cause yourself problems later down the line...

As for not getting an IP, all I can think of is that there maybe a subnet conflict between the WAN and LAN side of your router or DHCP on the WAN may simply be turned off - take a look and try again, but technically, there isn't really a reason why this shouldn't work.

| |
  • Well everything is working, it is just the the router itself expects Internet to some through the Internet port. So while it is routing everything correctly its GUI does not register a connection to the internet. So the routers internet bandwidth log/ip access display/ etc. is not working. It was not working earlier when I plugged it into the WAN port myself. – Jonathon Nov 12 '12 at 20:36
  • When it was plugged into the WAN port the router seemed to think it was connected correctly, but my computers could not connect. – Jonathon Nov 12 '12 at 20:38
  • Ah, DDWTR sets the WAN port onto a separate virtual lan. Changed it so everything uses the same vlan allows me to use that port. And I think I might be OK with the potential NAT problem, not that I really even understand what that is. Here is what I did: "Operating Mode: If the router is hosting your Internet connection, select Gateway mode. If another router exists on your network, select Router mode." So I put set Operating Mode to Router. Annoyingly, all this did was allow me to plug it into the right port, but as for logging and shoring my WAN address that is still not working. – Jonathon Nov 12 '12 at 21:08

Try switching the router to bridged mode. In this mode, both DHCP and NAT are DISABLED on your router and you rely on the providers router for those functions.

| |
  • Another possibility is to use your PC for a while, then (if the router provides the functionality), plug in your router with the "clone PC MAC Address" function, and use that's PC's MAC address. – kmarsh Nov 12 '12 at 20:57
  • Hmm, that is a really long tutorial just to set it to bridged mode. But interesting read none the less, I think I ended up doing all the important parts of this. It did not start my router logging bandwidth use, but it is still working. – Jonathon Nov 12 '12 at 21:04

You mention it's through a dish; does that mean it's satellite internet?

Satellite internet often operates quite differently to a regular internet connection. For starters, they're often behind Carrier Grade NAT (i.e. you get a 192.168.x.x or 172.16.x.x or 10.x.x.x IP address), and they're usually not regulated by the same rules that regular telecommunications companies are (because you could get your satellite connection from any company in any country that has a visible satellite really).

It sounds to me like what is happening is your satellite provider wants to provide all of your computers with their own IP address so that they can track how many users are on your connection. This may be their right - check your contract.

Otherwise, putting your satellite connection behind a NAT gateway (like your DD-WRT) should be possible. If you are not getting a DHCP address then it's possible that they are blocking certain MAC address ranges, or your DD-WRT is setup incorrectly (perhaps it's set to PPPoE when it's meant to be Direct/Ethernet?).

Either way, a quick call to your ISP should indicate to you whether or not they are actively blocking routers, or if there's just something going on with your setup.

| |
  • It sounds like it is just an extended wireless setup. There is some tower a few miles away that I need to see. So I am not directly connected to a satellite anyways. – Jonathon Nov 12 '12 at 20:58
  • Was this not obvious? The internet is working, it is just my router GUI/logging that is not recognising this connection as a connection. It is set to DHCP connection type right now. – Jonathon Nov 12 '12 at 21:01
  • @JonathonWisnoski - No sorry, that wasn't particularly obvious. Are you saying that your connection IS working behind DD-WRT? – Mark Henderson Nov 12 '12 at 21:13
  • Sorry, Yes I am using the Internet right now to type this message. It is simply the router that is somewhat confused. I do not know if it is an issue with DDWRT or most/all routers have this problem. but the router firmware does not see the internet connection and therefore does not display my WAN ip/log my usage, etc. – Jonathon Nov 12 '12 at 21:17
  • If I do not log into the router, nothign is wrong. It is just in the internal DDWRT interface that problems are apparent. – Jonathon Nov 12 '12 at 21:20
  1. "Internet Port" is the same as a generic ethernet port. A standard wifi router has 4 of them.
  2. Put your wifi router in bridge mode, define the default gateway the same as your CPE (Antenna/dish). Also configure your internal network IP or range.
  3. IF you have troubleshooted all you can, call the ISP. Engineers are dealing with these queries everyday and should therefore be able to help you over the phone.
| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.