1

I'm using Windows 8 Professional installed on Windows 7 using the "Save my preferences and apps" installation option.

The Windows works great, apps are downloading and I can listen to online radio stations using the TuneIn radio app meaning the internet connection is alive, however, when I open a browser (either Chrome or IE10) and try to browse the internet, I'm getting an "Unable to resolve DNS" error message. Prior to installing the internet browsing worked flawlessly I must say.

I'm using ESET NOD32 Antivirus so I suspect that it might interfere with the web connection now, but I'm not so sure. Internet options show that the PC is set to resolve the DNS automatically.

I don't know what to do. My other Win7 PCs in my wifi home network are connecting to the internet without any issues.

If anyone can help me resolve this I'll be grateful :) Thanks

EDIT: When writing "ping www.google.com" command in CMD, I get the IP of google resolved correctly, but when I try to input this same IP into the browser address bar, I get an error. It's worth to mention that I'm also using NOD32 Antivirus.

7
  • Perhaps, this is not the case, but check proxy settings in IE and make sure no proxy is configured there. Chrome uses settings from IE, that's explains why both browsers do not work. Some malware can change proxy settings for you, so if this is the case - check PC for malware. Nov 13 '12 at 21:58
  • Thanks for the suggestion, but the proxy seems to be configured correctly (no proxy is set, the internet options are set to get the settings automatically) I've talked to my ISP and I hope that I'll be able to fix it today. In the meanwhile I'm using my Win 7 laptop Nov 14 '12 at 6:01
  • Have you tried to disable NOD32 AV and firewall temporarily? Nov 14 '12 at 7:12
  • Yep, also didn't work :/ Nov 14 '12 at 9:21
  • Try to telnet google.com 80, this will allow to check if HTTP is allowed at all. Blinking cursor means - allowed. After that try resetting IE settings completely in Internet Options on Advanced Tab. Nov 14 '12 at 9:24
1

After talking to my ISP, they suggested to write the following command in my CMD (you have to run the command prompt as an Administrator)

netsh winsock r

This will release the network resources. Once this is done, restart your PC and browsing is back!

Thanks to all the helpers! :) I hope this will save some time to other people who encounter this issue.

0

It happends that a home router acts as a DNS server, assigns their own IP address as a DNS server, but fails to resolve DNS entries.

What if you change your DNS server settings manually on your windows machine (search for change adapter settings) to Google Public DNS servers 8.8.8.8 and 8.8.4.4?

2
  • I saw this solution somewhere else and haven't tried it yet, I'll try this tonight and post my answer here. In any case, thanks for the response :) Nov 13 '12 at 12:11
  • I tried using those two addresses, no luck :/ Nov 13 '12 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.