The problem

We are naming our various network volumes after Planets!

I renamed the Mercury.icns icon, to .VolumeIcon.icns and copied it over to the mount point folder of the NFS server. So far remounting the NFS share does not seem to employ this icon. Looking on the NFS server, there appears to be two VolumeIcon files.

Can someone tell me what I am doing wrong? Permissions? Do I need a .DS_Store file there as well?? It shouldn't be this hard!


Should have mentioned, the NFS server is Ubuntu 12.04.1. NOT an OSX server.


After much testing, using various methods (including the "copy-paste-get-info-icons one"), I cannot seem to get the NFS mount a custom icon. I could change the generic share folder icon, but then can't customize individually.

The solution may be an Alias file and somehow "hiding" the share from showing up on the desktop once it is mounted....


Just copying the .VolumeIcon.icns won't change anything from what I know. Instead, you need to set the icon of the volume directly.

To do that, you need to copy it from the .icns file to the Volume:

  1. Get Info (⌘I, or select it from the File menu) on the .icns file. If you see the custom icon at the top of the Info window (not in the preview section), click to select it, and copy it.
    • If you don't see it, you'll need to convert it to a copiable icon. Download IconDroplet and follow the above step to copy the icon from the file it creates.
  2. Get Info on the NFS Volume, select its drive icon, then paste in the custom icon. This will create a .VolumeIcon.icns and whatever other magic OS X uses to determine custom volume icons.
  • Thanks for your response. I did have a go of IconDroplet. It created an application (eg. right click, show package contents). And copying the icon across in the way you described didn't seem to work. That Mercury volume stubbornly refuses to change icon! – James Nov 14 '12 at 4:43
  • Perhaps test it by copying the icon to a folder first. That way you can isolate whether it's the copying process or something else that's going awry. – robmathers Nov 14 '12 at 5:13

I tried with a Samba share, but it should work the same with NFS.

Indeed, copy/pasting from the "Get Info" windows does not work. However, this worked:

  • open the .icns file in Preview
  • Select All and Copy
  • Paste (Cmd-V) on the share icon in the "Get Info" window

(Of course, that should be exactly the same as copying from the Get Info windows, but obviously it isn't in Lion 10.7.4).

This created the 2 files you would expect on the destination: .VolumeIcon.icns and it's resource fork ._.VolumeIcon.icns.

However, it also created another file which seems essential. It is displayed as ._. in the Mac Terminal, but got a weird name on the Samba share, probably to work around the illegal trailing dot.

(on my machine, Samba replaced the trailing dot with the UTF8 "private" character xEFx80xA9)

Update: Even when copying from Preview, it does not always work with NFS. It does sometimes!?!...

Copying the files from a FAT32 drive (which also has the extra ._. file) to the NFS share doesn't work.

What does seem to work reliably is terribly convoluted, but anyway, here it goes:

  • Use the method above to assign an icon to the Samba share.
  • On the server, copy the files created on the Samba share to the NFS share
  • Rename the weirdly named Samba file to ._. (dot underline dot) in the NFS share folder
  • Thanks mivk, I'll have to give this a go when I'm next in. – James Jan 28 '13 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.