I installed MySQL with homebrew. When I run mysql.server start I get the following error:

ERROR!The server quit without updating PID file (/usr/local/var/mysql...

I have searched this site and googled this and I do what it tells me to do but I've had no luck.

migrated from stackoverflow.com Nov 14 '12 at 4:59

This question came from our site for professional and enthusiast programmers.

  • 1
    Instead of any init.d script, start mysqld in the foreground without forking, and it will probably tell you why it fails. – Wrikken Nov 13 '12 at 22:57
  • Ok, I get the following error and I don't know how to fix it: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) – Jennifer Nov 14 '12 at 0:11
  • 1
    mysqld NOT mysql .... In other words: start an unforked mysql instance with stdout & stderr to your console. – Wrikken Nov 16 '12 at 13:13

What have you tried so far? Did you run the following after installation:

brew info mysql

If you did, it might be a problem with permissions. You might need to give the user permission to write to the PID file.

  • How do I exactly do that? I did sudo chown -R [user name] PID. This is probably wrong because I work with the hardware side of the computer not the software part until now. Thanks for your help! – Jennifer Nov 14 '12 at 16:53
  • Thanks for that - brew info mysql gives some useful info. – Dave Everitt Dec 31 '15 at 10:42

Firstly, you can use mysql_install_db to install your MySQL system tables. Then you can use mysql.server start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.