I can't get a screenshot because cursors are the only things that DON'T appear in those, but, seemingly at random, this awful long cursor replaces the regular cursor. I tried to draw it in Paint but it's hard for me to know where exactly the cursor is pointing! My attempt to draw the cursor in Paint.

This cursor has other states too: it substitutes a bunch of upward arrows in a vertical line for a hand cursor, a ladder with a bunch of diagonal lines sticking out and pointing down on either side for a resize window cursor, etc.

Eventually, if I right-click/control-click enough, it goes away, but not before my monitors go black for a second, and the computer seems to freak out a little bit (like it's redrawing stuff, but I I may just be making that up).

What is this? Is it actually a built-in feature that's trying to help me in some way? How do I get it to go away permanently? If it's relevant, I'm remoting into the computer this is occurring on.

7 Answers 7


Sounds like a graphics driver crashing based on the black screen and full redraw - look for a pop-up in the notification area next time it happens. In the meantime, check for updated graphics drivers for your graphics card.

  • I'll do that the next time it happens. Thanks!
    – user460847
    Nov 14, 2012 at 19:01
  • Yeah, it happened again, and when I minimized the computer window I was remoted into, the screens went black and the cursor returned to normal. Then I saw a message in the notification center saying that a graphics driver had crashed and then recovered. Unfortunately when I clicked the message it went away instead of opening up to give more details... ah well. I'll investigate more next time. Thanks!
    – user460847
    Nov 15, 2012 at 14:59
  • 2
    Thought that was probably it. Unfortunately it doesn't give any more details than that, although you may find something in the Event Viewer and it may appear in the Action Centre to allow a report to be sent. Nov 15, 2012 at 15:22

I just had this issue and I was able to fix it by quickly shaking the mouse back and forth on the screen that was having the issue. Based on my symptoms and this forum link, I would say it has something to do with the graphics card/driver. I didn't update my drivers, though, and I have not had the issue again.

I have a three monitor setup and the cursor was only messed up on one of them - as I would move the cursor between the different monitors, it would go back to normal on two of the screens, and appear as the glitch on the one. I'm not sure if it was necessary that I shake it on the screen having the issue, but that's where I tried it and it went away.


It's a bug in the AMD/ATI software and it's been there for some time.

If you need a quick fix and restarting isn't an option, go to Control Panel > Mouse > Pointer Options > enable Display Trails. Then disable after restart to maintain your sanity.

  • This works, but as soon as you disable it (no restart), it looks weird again.
    – Imagin
    Feb 14, 2017 at 9:33

Same thing has happened to me, if rarely. Cursor changes from arrow or hand to just some vertical white dotted lines. Nothing showed up in the Event manager. Solution was to unplug my USB optical mouse for a few seconds and plug it back in.


I have the same issue.....cursor suddenly turns into what can only be described as a straight vertical line about 10mm long with around 6 'hairs' attached to it on the right hand side...

Unplugging the usb mouse for a few seconds fixes it


Hovering over the 'show desktop' bit on the right hand side of the taskbar fixes it for me.

Tip taken from here


In the text fields or in text editor, generally cursor does not display correctly. It can be fixed with below steps.

  1. Click on Start > Type 'Mouse' and open it
  2. in the 'Mouse Properties' > Go to 'Pointers'
  3. in the 'Customize' field, scroll down and select 'Text Select' > Then click on 'Browse'

    Mouse Pointer Image

  4. in the new opened 'Browse' window, select any mouse cursor icon and click 'Open'

  5. Click 'OK' to close the 'Mouse Properties' window

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .