3

I don't want ConEmu to attach to every cmd I open, but this is how it works now. I remember that I told ConEmu to do this, but I don't want it anymore. Maybe I just overlooked something, but I've read all the settings pages and I couldn't find an option to disable it. Am I missing something?

How do I prevent ConEmu from attaching every single cmd.exe I open?

My ConEmu version is 121109 x86, on winXPproSp3x86.

2 Answers 2

3

Settings -> Startup -> ComSpec

Press "Unregister" button.

2
  • I was overlooking it after all! Thank you very much!
    – n611x007
    Nov 15, 2012 at 0:11
  • Doesn't seem to work in current ConEmu. Even if "C:\Program Files (x86)\clink\0.4.7\clink.bat" inject --autorun --profile ~\clink is the current content, it is still auto attached. It seems that there is some other setting. Maybe, I have chosen once to attach a cmd.exe window and that is stored at other places in the config
    – koppor
    Jul 18, 2016 at 13:08
1

I came here looking for an answer to why doing:

Start-Process powershell.exe '.\MyScript.ps1'

within PowerShell in a ConEmu would launch it in a new ConEmu tab rather than cmd.exe (ComSpec).

To stop ConEmu from doing this, within Settings → Features, under "In-console options", untick "Inject ConEmuHk".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.