I have an error by installing and executing the apt-get (there is no package manager except udpkg):

apt-get: /usr/lib/libstd++.so.6: version GLIBCXX_3.4.15 not found (required by apt-get)

I have the library /usr/lib/libstd++.so.6 there.

  • 1
    Oh boy, this is a bad (and fairly common) error. It sounds like you probably upgraded your system between incompatible versions of libstdc++, and in so doing, you installed an apt-get that is no longer binary-compatible with your C++ standard library. What mechanism did you use to upgrade? – allquixotic Nov 15 '12 at 13:46

You have libstdc++6, but there are sub-versions within that and you've ended up with a 'wrong' version somehow. It's possible you have multiple sub-versions present and libstdc++.so.6 is linking to the wrong one. If you only have the one (wrong) version, you could try downloading an rpm of the version apt-get is expecting from a website.

For any other program failing in this way I'd suggest upgrading either library or program via the package manager, or recompiling the program against the version of the library you have, but given that it's apt, I don't think you could do either easily..!

This post might help?

  • I cannot build a new one (I have no gcc, it is only an ash with busybox tools), and all that are from debian.org do not work. – static Nov 15 '12 at 14:59
  • I have the version from your post (4.4.5-8) – static Nov 15 '12 at 15:07
  • Hm, I don't know that much about what's provided by busybox and what isn't. Has apt-get ever worked on this box? What's the output of strings /usr/lib/libstdc++.so.6 | grep GLIBCXX? – jam Nov 15 '12 at 15:31
  • I managed it, starting from the beginning :) – static Nov 15 '12 at 16:09
  • Glad you fixed it! Any idea what had caused the problem? – jam Nov 15 '12 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.