I can't type into e.g. facebook's log in form with my computer. I hit my keys, but nothing happens. Special characters like č, ć, š, etc. work. Backspace doesn't, delete does. This goes for Internet Explorer, Firefox and Chrome.

This also happens with some other sites, sometimes even with gmail (or any google's log in form).

I read somewhere that the solution is to reregister some dlls:

regsvr32 mshtmled.dll
regsvr32 jscript.dll
regsvr32 /i mshtml.dll

The first two work, the third one says

The module "mshtml.dll" was loaded but the entry-point DllRegisterServer.dll was not found.

And of course, running just the first two didn't help. Does anyone know how to fix this problem?

  • and is it same with EN layout? – dmnc Nov 17 '12 at 17:22
  • Yes, for english it's the same thing. I can type characters like [{}] (which are the same keys as šđ on the croatian layout), but I can't type normal letters and numbers. – Zoltán Nov 17 '12 at 17:47
  • Strange!!! Does the problem occur just with textbox or with textarea(say FB Pot box, gMail Message body)etc. as well??? Does it work fine in other apps such as Notepad etc.? – Viral Jain Nov 20 '12 at 9:24
  • I'm not sure for those multiline textboxes. Other applications work fine. I'm guessing it's a problem with javascript. P.S. why all the exclamation and question marks? – Zoltán Nov 20 '12 at 12:31
  • Do you have any user scripts extensions installed ? – Ankit Nov 22 '12 at 18:21

I too had the same problem. Turned out to be a registry issue which was fixed by CCleaner.

How I fixed it:

  1. I downloaded CCleaner.
  2. Installed it, opened it and navigated to Registry tab.
  3. I ran the registry scan. fixed all the reported issues.

enter image description here

  • OK. It's fixed in Firefox now, but IE and Chrome are still not working. Not sure whether an update for Firefox fixed it, or was it the registry cleanup. – Zoltán Nov 25 '12 at 15:18

You can try these commands: Start->Run and type the command: regsvr32 /u mshtml.dll and click Ok. Then Start->Run and type the command: regsvr32 mshtml.dll and click Ok.

See, if this fixes the issue.

  • Thanks, but mshtml.dll can't be installed or uninstalled because it doesn't have a DllRegisterServer entry point on win 7. – Zoltán Nov 25 '12 at 15:05
  • Try to download System Mechanic and scan your PC with full scan. You will see the errors listed. Try to fix these errors and see if your issue gets fixed. System mechanic offers a trial version, so you can download it and use it within the trial period. – Manoj Agarwal Nov 26 '12 at 5:02

i posted a solution with ccleaner but after a day a problem has apear again to me, and i couldn't solve it again. but there is another solution that must work.

first download subinacl http://www.microsoft.com/en-us/download/details.aspx?id=23510

then after install download and run batch http://borris83.googlepages.com/reset.cmd

it take some time so dont worry, just let it work to the end and dont close it until it close it itself

good luck, please let us know did it work for you

  • OK, that'll probably be next week because I currently don't have access to that computer. Thanks. – Zoltán Dec 3 '12 at 9:05

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.