I have a Windows8 computer linked to the internet via an ethernet cable ("Ethernet" network connection). I have attached to it a DLink Wifi USB stick, and I'm trying to share the main PC's internet connection with my Android phone via a local wifi network. I am using the following batch file to set up this network:

netsh wlan set hostednetwork mode=allow ssid=MyWifiName key=password keyUsage=persistent
netsh wlan start hostednetwork 

After I run this script, I can see a new network connection appear in "Control Panel\Network and Internet\Network Connections" named "Local Area Connection *12", and I can see "MyWifiName" on the Android phone. The device name for this connection on the PC is "Microsoft Hosted Network Virtual Adapter". I also set up the "Ethernet" connection to share Internet with "Local Area Connection *12".

However, the Android phone usually doesn't manage to obtain an IP from the wireless network, and when it does, there still seems to be no connectivity to the internet. When I turn off the Windows Firewall completely, or even just for "Local Area Connection *12", the Android connection is perfect.

My questions are:

  1. How should I set up the Windows firewall to allow the phone to connect properly? Is there a specific rule I need to add to the Windows firewall advanced settings? [Note: the above method worked great in Windows 7, without any specific tinkering with the firewall].

  2. Is it safe to turn off the firewall specifically for the "Local Area Connection *12" (the wifi connection) if the main Ethernet connection is still protected by the firewall?

Thanks in advance.

EDIT: Some new information:

Seems like the problem is also connected to how many devices are trying to connect. Apparently the wireless network I've set up doesn't allow (for unknown reasons) more than one concurrently connected client. I haven't noticed this before since my tablet that was somewhere in the room was connecting to the network automatically, thus leaving the phone with no connectivity.

So I guess the updated question is : why can't I connect more than one device to the network? (No problem doing that in Windows 7.)

  • Have you tried static IP address? Because I had the same problem but after setting a static IP, it works fine(my adapter is TP-Link TL WN721N).
    – RogUE
    Apr 27 '15 at 3:16

It sounds like the DHCP requests from the Android phone might be getting blocked. If you trust all the devices that will connect to your hosted network, you can probably get away with disabling the firewall, just make sure you're using a strong wireless password. Alternatively you could keep it on and create an inbound Windows firewall rule to allow all traffic from that IP address. You'd have to create a "custom" rule (if it's like in Windows 7).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.