I just purchased an Asus Zenbook Prime UX31A-DH51 with Windows 8. I want to wipe the drive and do a clean install but USB is not listed as a boot option in the BIOS. Does this mean it is not possible?

Here is a photo of my BIOS options.

enter image description here

This is the only option I get when I click Add New Boot Option. Not sure if I can add USB here.

enter image description here

***** Update ***** Asus tech emailed and said: "Unfortunately with Windows 8 you can not boot from bios."

  • 1
    What happens when you click on "Add new boot option", it should give you the option for USB. Nov 17, 2012 at 23:45
  • 1
    Can you try this? Press Escape to get into the boot menu. If the USB bootable device is not listed, enter the configuration menu and directly press F10 to save. Press Escape again on reboot: This time the USB bootable device should appear in the menu. ( Source: wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A )
    – Hennes
    Nov 18, 2012 at 0:12
  • 2
    Drat. One more question: Is USB legacy support turned on or off. ( This is mostly needed when emulating older PS/2 keyboards and mice for an OS which does not support USB. E.g. DOS. However it also affects some USB boot options. )
    – Hennes
    Nov 18, 2012 at 17:10
  • 1
    Can you insert the USB stick, reboot, press Esc during the Asus splash screen to bring up the EFI boot menu and post an image of the same? Also, in the second BIOS screen you clicked on Select Filesystem. What about the top-most Add boot option or Path for boot option or even Create, with the USB stick plugged in? As a last resort maybe you can try Launch CSM to enable legacy BIOS booting and see if that allows you to boot from USB or not.
    – Karan
    Nov 18, 2012 at 23:07
  • 1
    Asus tech emailed and said: "Unfortunately with Windows 8 you can not boot from bios." - Even if you enable Launch CSM (Compatibility Support Module)? (See my full comment above.) A modern machine being unable to boot from USB boggles the mind. Makes me suspect the support guy is typical of his breed.
    – Karan
    Nov 21, 2012 at 17:22

18 Answers 18


I just went through the same pain... but I found a workaround.

  1. Plug in your USB drive
  2. Turn the Zenbook on
  3. Enter UEFI (BIOS) through pressing ESC or F2
  4. In 'Boot' tab: 'Disable Fastboot' (*)
  5. Press F10 to save & exit
  6. Immediately press ESC or F2 again
  7. In 'Boot' tab: your USB drive should be listed - change the order
  8. Press F10 to save & exit
  9. Your Zenbook should now boot from the USB drive
  10. profit

(*) = and 'Enable CSM' if you want to boot in legacy mode

If that does not help, you might need a more recent firmware version.

Just in case you run into more trouble while trying to install Windows onto your GPT SSD - this post might be very helpful: http://www.hodgin.ca/2012/10/02/creating-a-uefibios-windows-7-usb-and-installing-to-gpt-partitions/

  • 6
    I had the same problem. I went into BIOS, Boot tab, then enabled Launch CSM...F10 to save and exit, hit Esc on restart and I get that menu where I was able to select USB to boot from. Thanks for the help guys!
    – Jim Syyap
    Mar 22, 2013 at 10:40
  • Enabling CSM did the trick for me. Although my situation was slightly different: I wanted to install Win7 on my Zenbook running Win8. Bootable USB drive would only show up in UEFI when CSM was enabled. Thanks!
    – simon
    Apr 21, 2013 at 15:30
  • I have a similar BIOS setup utility - your wording is contradictory on step 4. It took me a bit to realize that disabling fastboot and enabling CSM are mutually exclusive - leaving fastboot enabled and enabling CSM gets me the results I need.
    – p0lar_bear
    Aug 9, 2015 at 16:35
  • 1
    I suggest putting step 4 bold with blinky tag and arrows. That was the dealmaker in my case! Thanks Sep 6, 2015 at 18:24
  • For people of the future™: Setting the installer drive to GPT (UEFI only on Rufus) solved my issue where the USB drive didn't show up, though I needed to follow this answer too.
    – ave
    Aug 2, 2017 at 22:03

We just got a few of these in at work and they are a right PITA to wipe and clean-install windows with, especially the usb-3 only ones.

To enable booting to a USB device you need to set secure boot to disabled (in the security tab of the bios) and enable CSM (on the boot tab of the bios)

You can then select a USB boot device.

If you are trying to install windows 7 on a USB3 only zenbook, your next headache will be windows setup failing, from either a bootable USB memory stick or a USB DVD drive. This is because the bios loads the windows boot image, but when the windows setup program starts it doesn't have USB3 drivers and can't read the setup files.

To get around this you need to create a customized windows setup, on either a USB memory stick or a DVD. You need to download the USB3 drivers from asus, extract the driver files (from the folder containing the .sys and .inf files) and use dism.exe to load these into a windows boot image. There are tutorials on how to do this on the net, the one I used was here: https://forums.mydigitallife.net/threads/how-to-install-windows-7-from-a-usb-3-0-thumb-drive-fast-installation.32302/

  1. Power on
  2. F2 to enter BIOS
  3. Tab to Boot
  4. "Secure Boot" -Disabled
  5. "CSM + UEFI" selected in OS Mode Selection
  6. F10

  7. Hold F2 to Enter BIOS

  8. Check boot -> Boot Priority to see if connected USB is listed

I use sandisk Cruzer.

  • This was the solution... Nov 15, 2013 at 18:48
  • Thank you! Very important to enable CSM and UEFI (or Legacy + UEFI in my case)
    – kryo
    Sep 12, 2016 at 20:58
  • the disable secure boot safe the day yay, now everything is listed Feb 27, 2018 at 2:21

I hit this same issue. However, if you plug in the USB stick before you boot, the choice will turn up. You can then save and boot away.


I tried to boot onto an Ubuntu USB - I see the grub loader but nothing happens after that. But that's a different issue :-)

Last note: Once you remove the USB stick, it will disappear from the options. Next time you want to bot from USB (or a USB DVD, whatever), you'll need to do this again.

EDIT 12-12-12: OK, I managed to get this working with Ubuntu. What I needed to do was turn off the "Secure Boot" option in UEFI/BIOS. Once I did this, it was pretty smooth sailing. Ubuntu installed and all was well with the world once more. This page here: https://help.ubuntu.com/community/UEFI was the best help I found.

Note: Disabling secure boot also meant that I had no issues at all getting both a USB and USB CD-ROM to appear in the boot menu on startup (hitting ESC). You do need to have them plugged in on boot (as it happens so fast), but messing around with the boot order as I mentioned previously became unnecessary.

As always, YMMV - this worked for me, I hope it helps you.

  • Mine still does not show up. What BIOS version are you on? Mine is 214. Nov 18, 2012 at 13:39
  • Sorry, I'm not able to check now (I was doing this on a friend's machine - I'll ask them). It's a brand new machine, so assume the latest bar maybe one or two revisions - max. Nov 18, 2012 at 13:55
  • Just looked at your screenshot more closely - the one I was using was definitely different with more features. I suggest you perhaps update the BIOS (although it's pretty odd it can't pick up a USB stick. Hello? 2001 called, they want their tech back) Nov 18, 2012 at 13:58
  • Darn, sorry Chace, I totally forgot to check the BIOS version. Dec 12, 2012 at 8:56

This thread helped me a lot. I'll add my 2 cents:

Asus R509C with Windows 8 pre-installed:

  • USB device is plugged in
  • F2 to BIOS
  • Switch to "Boot" and set “FastBoot” to Disabled
  • Switch to "Security" and set "Secure Boot Control" to Disabled
  • F10 to save and exit and immediately press F2 to BIOS
  • Only then could I switch to "Boot" and set “Launch CSM” to Enabled
  • F10 to save and exit and immediately press F2 to BIOS
  • Now select a boot option. My USB option didn't say USB, it was just [ 8.0.7]
  • F10 to save and exit - booted right to USB

Those are not BIOS setup screens, they are UEFI setup screens (which is the successor of BIOS). Note that UEFI cannot per se boot from media that are made bootable for a BIOS (like install media for most operating systems or rescue systems, which were released at a time where UEFI was not yet available, like last year or so) unless you enable CSM (compatibility support module) support.

So, either you have a boot media that is UEFI bootable (maybe in addition to bootable via BIOS), then you just have to attach it and it should be possible to select it in that menu, or your media is "only" BIOS bootable, then you have to enable CSM support and reboot and go into the BIOS setup of the CSM module to configure booting it from there.


I just had this same problem with exactly the same symptoms on an ASUS K56CA that I unboxed yesterday, and boy I am glad I did not come to this thread first. Lots of good advice, but none of it (would have) helped me!

Try a different USB stick. I was using a U3 16GB stick that never had problems booting on any BIOS-based computer, and I could never get it to show up reliably in the boot menu. (Once it appeared in F9 menu, only after I had removed it during boot.)

I switched to a 2GB "24x" PNY Attache I had lying around, with no embedded U3 partition, and it showed up immediately when I had any EFI-supporting image copied to it. Unfortunately I still was not able to boot from the USB. (Grub would load, but no love after selecting any choice from the boot menu.)

Finally I was able to boot Ubuntu using a DVD media with the same image written to it. The helpful folks in the #ubuntu /freenode IRC channel informed me that you do not need a special image secure-linux-12.10-anyfoo.iso as the Ubuntu guide instructs, just use an up-to-date 12.10 amd64 image and it will have included EFI booting support.

For me, after all this, it happily showed up in either F9 or ESC menu for alternate booting.

  1. Enter the BIOS setup menu by pressing and holding F2 key when powering on.
  2. Switch to "Boot" and set “Launch CSM” to Enabled.
  3. Switch to "Security" and set "Secure Boot Control" to Disabled.
  4. Press F10 to save and exit.
  5. Press and hold ESC key to lunch boot menu when the notebook restarts.

I found this: http://www.makeuseof.com/tag/how-to-access-the-bios-on-a-windows-8-computer/ - this might help you out but I am still having issues booting to a device...


Strangely, despite all proposed answers, my USB drive was still not appearing.

The USB drive finally appeared just after I hit Ctrl+Atl+Del after boot.  It re-boots, I hit Esc, and the USB Drive is now in the menu list available for choice.

It was as if the booting sequence was too fast for my USB drive.

It worked for me.

  • 1
    We’re glad you solved your problem, but this may be just a variation on the “plug in the USB stick before you boot” answer.  (Did you try that?) Nov 27, 2020 at 15:25
  • Can't say, but I'll keep that in mind next time. thx. Nov 27, 2020 at 21:06

All recent hardware supports booting from a USB drive. Look for "boot" in the contents index and flip through those pages 8^).


Boot from USB on APTIO SETUP UTILITY for a 2012 American Megatrends BIOS

  1. Enter the BIOS setup menu by pressing and holding F2 key when powering on.
  2. Switch to and set to Enabled.
  3. Switch to and set to Disabled.
  4. Press F10 to save and exit.
  5. Press and hold ESC key to launch boot menu when the Unit restarts.
  • +1 for holding the xx key when powering on!
    – MTAdmin
    Jan 3, 2020 at 22:38

Wrong information that it is not possible. Just create bootable USB for UEFI not MBR and machine will recognize it and show in BIOS as possible boot option. Bootable USB with Windows 8/8.1 for UEFI can be easily created via Rufus software or on the internet is many tutorials using command line. I had the same problem as you because I have created firstly USB for MBR by mistake instead of UEFI.

enter image description here

  • True, it's changed now, but here's the updated look: superuser.com/a/1605528/35525 The ONLY way to boot from USB using a Asus VivoBook Max X541N is to use this method of burning the UEFI:NTFS image in rufus first, and just manually copy the contents of the iso onto the USB after that. Nov 27, 2020 at 14:45

I had the same issue. And activate the CSM option in UEFI menu was not a solution because then I couldn't install windows as my HDD drive was set in GPT (and not in MBR). And if I unset the CMS option, the USB stick was no longer detected... Actually, I realized that my bootable USB stick was not correctly set on UEFI mode, that I could do using the Microsoft media creation tool (or Rufus). Once done, my USB stick was immediately detected in the boot menu, and I could boot from it and install Windows.


If your USB drive does not show up, try a different drive.

I couldn't get it to boot from USB DVD on two different model Zenbooks. It wound up being a compatibility issue with the DVD drive. A new DVD drive booted just fine.


I had only two options when assigning to boot priority 1 and 2 - they were (a) CD/DVD and (b) hard disk. USB was not an option.

My solution so as to allow booting from USB was:

  • Ensure USB key is connected first and power on PC
  • Within BIOS go to "Disks" and attempt to change value. Hopefully "USB" appears here now - if so select it.
  • Still within BIOS go back to boot priority assignment and now "USB" will appear as a selectable value/option.

Your BIOS can now boot from USB.

NOTE: My BIOS had only two boot priorities - I was using USB and CD/DVD. Therefore I had to reverse the change mentioned above, i.e. change the hard disk within BIOS back to the hard disk, and then within boot priority no 2 assign it to the hard disk. So that PC would boot from the hard disk.

  1. Get USB
  2. Install Linux/Ubuntu on USB
  3. Insert into PC
  4. You will see the USB option
  5. Install Linux on PC.
  6. Then Install Windows in the same USB

This is when In my Scenario, No DC/DVD drive, Only Guest Access and limited BIOS access.

  • 1
    This doesn't seem to answer OP's question.
    – confetti
    Aug 18, 2018 at 13:47

In a word, no. When you have the machine set to boot using UEFI (Launch CSM is set to Disabled as shown in the first screenshot in the question), you'll only see USB-related stuff in the Boot section if plugged in UEFI-bootable USB devices were detected, with the added wrinkle that they have to have been plugged in at the time the 'Aptio Setup Utility' was starting as that's the only time it looks for devices.

The absence of that doesn't mean your system can't boot from USB generally. At the risk of making a huge generalization, UEFI-capable machines with AMIBIOS from 2012 and built-in USB ports are all capable of booting from a properly partitioned and configured USB device, provided that booting from USB isn't totally disabled in the Security section.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .