I have a custom built rig that has 2 storage drives.

for OS: Western Digital 1.0TB HARD DR 64MB

for other stuff: Corsair Performance 3 128GB (SSD) [ expected read speed: 400 mb/s ]

The system was incredibly fast for a couple of months, then one day i was playing a game then it started to get buggy (some sounds and objects disappearing), i stopped the game and the system seemed to be unstable so i had to shut it down, next morning i couldn't start it up, it was saying something about corrupt device.

I formatted both disks and installed a fresh copy of windows, all i can say that since that day the system was never like before, it takes 10 minutes to boot up (the icons and desktop slowly appear). but once it's done the slowness isn't as noticeable.

Here's my benchmark on the HDD ( read speed - write speed ):

enter image description here

And the SSD:

enter image description here

Anyone knows what could be the issue?

  • Heat would be my first guess. I would check all fans first and make sure the heat sink is properly mated to the CPU. Check CPU temperature under load. – David Schwartz Nov 19 '12 at 0:14
  • The CPU runs at an average 51 C on 3.6Ghz (OC'd from 3.2) – CodeOverload Nov 19 '12 at 0:16
  • What's the peak temperature? And what CPU is it? – David Schwartz Nov 19 '12 at 0:19
  • It's i7 960, on maxed out graphics games the CPU can hit 75 C – CodeOverload Nov 19 '12 at 0:36
  • Have you overclocked the CPU? And which device was said to be corrupted? – harrymc Nov 24 '12 at 6:51

Boot into a linux live CD and then try a benchmark to see if the performance there is better. You can use an Ubuntu live CD and just try running something like this:

dd if=/dev/sda of=/dev/null bs=512k count=2000

This will copy 1GB of raw data from /dev/sda to nowhere. Let it run (it will take a little bit) and when it completes it will give you an output like this:

2000+0 records in
2000+0 records out
1048576000 bytes (1.0 GB) copied, 45.1907 s, 23.2 MB/s

If the throughput you see is closer to expected then the issue is likely in how Windows is configured. Since you reinstalled this is unlikely but still possible. If the output is still slow like you're seeing now then it's likely in your hardware or hardware configuration.

If it's hardware try removing the overclocking and trying in linux again. If that still doesn't work check your SATA settings and memory settings. If there's nothing odd you could save your BIOS config (almost all support this) and then reset to factory defaults and try again. If it still is slow there's definitely a hardware issue. If not then there is a problem in the configuration.

It sounds like your overclock (and the heat) may have fried something or is at least set too high considering the errors your described seeing and hearing in the game. That's usually indicative of a hardware failure or and overclock that's unstable.


Given your peak CPU temperature of 75C, the issue is almost certainly heat. You need to keep the CPU temperature around 65C or so even at full use, otherwise the CPU throttles. It sounds like you never finished overclocking the CPU and didn't actually test whether the CPU could run stably at 3.6GHz without throttling. This overclock is actually making the CPU slower and is making its performance bursty.

Note that you can't accurately assess whether the CPU is throttling by watching the case temperature. The throttling is based on the core temperature which changes much more quickly than the case temperature. If you're hitting the case temperature limit at sustained load, it's quite likely you're hitting the core temperature limit during load bursts.

  • 1
    It's the same even if I disable the OC profile, also i've heard of many people that for my CPU, only above 95 C is not safe. – CodeOverload Nov 23 '12 at 21:10
  • Tjmax is when throttling occurs, and it certainly isn't 75c for this model CPU. Also the OP stated that he only reaches this temperature during gaming. – SpellingD Nov 27 '12 at 17:20
  • @SpellingD: Read my second paragraph. His temperatures are most likely case temperatures, not junction temperatures. – David Schwartz Nov 28 '12 at 23:25
  • @DavidSchwartz Sure, the OP was not specific on how he measured the temperature, so that could be plausible, but I still would be very surprised to see a 20C difference in case and core temp. – SpellingD Nov 29 '12 at 16:30
  • @SpellingD: It's not unusual if load is bursty. The core can heat up a lot faster than the case. – David Schwartz Nov 29 '12 at 16:36

Shot in the dark but you might want to run spinrite or a program that will access each sector. Some times this helps with helping the drive discover sectors that arent acting up to par and mark them as unusable.

Have you tried looking for a newer firmware for the drive?


First thing firsts, as my experience always it's better to use SSD for OS and/or swap file and WD 1 TB for storage, that increase performance and boot time.

I had same issue many times , and here the solution that make system back to life again.

  1. If you have a hard disk failure (such a bad sector) overall system IO performance decreased so check smart status of your western digital 1TB hard disk.

  2. Please remember check your SATA cables. I know it's crazy but I have sudden cable issue before.

  3. Did you test using only SSD and check the performance of your system.

  4. Always keep your SD firmware up to date.

  5. Remember to check system io performance when system not overclocked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.