1

I've been experiencing strange download behavior in a torrent manager on archlinux. Whenever I try to download a torrent my speed starts dropping and getting back to the same level again and again.

For example: my max speed is 250 kb/sec in any torrent manager, as soon as I start a download the speed gradually drops from 250kb/sec to 100 kb/sec and then to 0 kb/sec in ~30 seconds, when it reaches 0kb/sec it starts increasing up to 250kb/sec back again. The cycle continues for the period of the torrent download.

I can overcome this issue by setting "no encryption" in torrent download settings. When "no encryption" option is used, the speed stabilizes and does not jump. This behaviour is being noticed in any torrent manager I tried. I didn't have this issue on debian with the same configuration.

ADSL modem configured in bridge mode.

What can cause this issue? Any ideas?

4
  • What ISP do you use? It could, possibly, be a function of their system and may be worth checking into.
    – nerdwaller
    Nov 19 '12 at 15:08
  • I don't think it is ISP, since everything was ok in debian with the very same config. I can ask them after all, but maybe there is something you guys know here.
    – minerals
    Nov 19 '12 at 15:10
  • Disable the system firewall and try it again. A boneheaded firewall rule (like blocking all ICMP) can do this. Nov 19 '12 at 15:29
  • I must have missed the debian piece, my apology.
    – nerdwaller
    Nov 19 '12 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.