So, I was just randomly digging around my laptop and found a couple of weird things. First, the Windows Experience Index goes through its motions, completes all the tests and then throws up this error:

enter image description here

First, I assumed Windows was just paranoid and tried it again but the same result. I ran sfc /scannow and no clues there. I googled and saw many people have a problem with WEI so I let it pass. But when I was digging the event viewer, I found this among a bunch of harmless Warnings

The platform firmware has corrupted memory across the previous system memory transition. Please check for updated firmware for your system

enter image description here

After some more googling, I found that is due to outdated BIOS firmware. However, this is on an Apple MacBook Pro 9,1 Mid 2012 15 inch non retina which also doesn't have BIOS as such. Bootcamp apparently uses some sort of BIOS emulator (forgive me, I don't know the technical details). Well, the error sounds alarming enough to me and I just clubbed them as I thought they're related. The HAL error comes after I wake up the system from sleep but it doesn't come every time. Just sometimes. Is my registry borked or something? Or is it nothing to worry about?

I have also noticed that Expression Studio refuses to install (it worked fine on Windows 7) saying license key is invalid. A Microsoft Support article gave a Fixit (and also says it is a registry issue) but that is only for Windows 7 and when I run it, it says incompatible system (I'm on Windows 8 Pro).

Sorry for posting so many errors at once but I just feel they're somehow related to each other. I have done a refresh and reset (yes, both) in the past and it doesn't help. These things somehow keep popping up.

EDIT: WinSat.log file is uploaded here: http://sdrv.ms/Wx8XB9

  • Open the file "C:\Windows\Performance\WinSAT\winsat.log" and look for the complete error message. – magicandre1981 Nov 19 '12 at 21:35
  • Can't understand anything in the log file – pratnala Nov 20 '12 at 1:30
  • upload the log file to your SkyDrive or Dropbox and paste a link here. – magicandre1981 Nov 20 '12 at 7:53
  • @magicandre1981 Added – pratnala Nov 21 '12 at 12:51
  • ok, you get the error "exe\processwinsaterror.cpp:0298: Unspecified error 48 occured." This user has the same issue: eightforums.com/performance-maintenance/… But I have no idea how to fix this. Disable all 3rd party tools (like Antivirus tools) and try to run WinSAT again. – magicandre1981 Nov 21 '12 at 15:24

The problem was a corrupted DLL file somewhere. Refresh solved it.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.