I've added Hyper-V to my Windows 8 Pro install. The CPU is an Intel i7-3770, so I believe it supports virtualization (which I've also enabled in the bios).

When I create a new Virtual machine I am unable to connect to it via the Hyper-V Manager. I can see the VM is running in the small thumbnail, but I can't access it.

Cannot connect to the virtual machine. Try to connect again. It the problem persists, contact your system administrator.
Would you like to try connecting again?

Cannot connect to the virtual machine

By default only the Hyper-V Virtual Machine Management service is running:

Currently Running Hyper-V Services

I've tried manually starting the "Hyper-V Remote Desktop Virtualization Service" as its description of providing a platform for communication between the virtual machine and the operating system running on the physical computer sounded promising.

This resulted in a prompt:

The Hyper-V Remote Desktop Virtualization Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

9 Answers 9


I found my specific issue. The VPN software that I used was preventing me connecting to the virtual machines. I uninstalled the VPN software and it worked fine.

The VPN software was Astrill, which I use to test CDNs and how websites look when connecting from various places around the world. This may no longer be an issue with the latest version.

I'm now running the VPN from within a virtual machine, which works fine and doesn't interfere with the Windows 8 network stack.

  • that didnt work with NordVPN Oct 29, 2019 at 22:29

I fixed it by allowing VMMS.EXE (Located in C:\Windows\System32) through my firewall (Sophos) and allowing IPV6 traffic.


I've found out that it was the proxy server that prevented me to connect to Hyper-V virtual machine.

Proxy is actually forced by group policy so this is actually just a workaround for me, but if I set UseProxy setting in registry to 0, I can connect to my virtual machine

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Terminal Services] "AllowExplicitProxyName"=dword:00000001







Go to Hyper-V setting in your Hyper-V manager. Then turn off NUMA Spanning and restart Hyper-V Virtual Machine Management Service. Before I tried everything. Finally that one works!!!!!


In my case it was problem with the Cryptographic service (VipNet CSP). You should unchek "Support work ViPNet CSP via Windows cryptoAPI" and reboot.


I had to enable the traffic for vmms.exe (virtual machine management service) on my firewall (mcafee)


Check your host file to make sure you don't have a manual DNS entry. That fixed my issue.

  • 3
    explain how to do that? May 2, 2014 at 16:43
  • open the file C:\Windows\System32\drivers\etc\hosts end check entries like this one : rhino.acme.com
    – must19
    Jun 6, 2014 at 23:00

Stopping the Hyper-V service then starting it again fixed it for me.

Stop Hyper-V Service


I had the same error but in my case eset's firewall was messing things up so if you have a 3rd party firewall try to disable it and see if that works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .