When using my Windows 7 PC, the Ctrl+Y keyboard shortcut does nothing. Interesting notes:

  • Choosing the same command from the menu works (such as Edit > Redo)
  • Both the Ctrl and Y keys work fine independently of each other
  • Any additional combination of keys works fine (Ctrl+Alt+Y, Ctrl+Alt+Shift+Y, etc)
  • For programs where Ctrl+Y is not the shortcut for Redo (in Adobe Illustrator, Ctrl+Y switches to Outline view), the shortcut still does not work.

So, it seems that something is globally preventing the Ctrl+Y combination (and ONLY that combination) from working properly.

I'm using a Microsoft Natural Ergonomic 4000 keyboard with Intellitype Pro installed, and Windows 7 64-bit. I also have a Logitech Performance MX mouse with their Control Center software installed, but I've disabled it for testing.

Here are the troubleshooting steps I've tried (with no effect):

  • Using another keyboard
  • Booting into safe mode
  • Connecting to the PC via Remote Desktop
  • Disabling all non-essential services
  • Upgrading Intellitype Pro to the latest version (Mouse and Keyboard Center)

Can anyone think of what may be causing this, or of any utilities that might help me track down what is suppressing this shortcut?


  • Have you tried uninstalling intellitype and then trying CTRL+Y? Have you done a virus\malware scan on your system?
    – Thraka
    Nov 21, 2012 at 22:09
  • Do you have anything installed/running which might be globally intercepting keystrokes? eg. AutoHotKey? Can you define CTRL+Y as a shortcut in another application that allows you to define your own shortcuts by automatically reading the pressed the key combination (can't think of any right now, sorry)?
    – Luke
    Nov 22, 2012 at 0:24
  • Were you able to figure this out? For me, ctrl+y and ctrl+e are the only two letters that don't work.
    – Anonsage
    Jun 18, 2014 at 1:45

2 Answers 2


I had the same issue, due to a Zen Coding plugin in Notepad++ that uses Ctrl+Y for something else. Given that Notepad++ is always opened on my computer, it blocked the keyboard shortcut everywhere.

Removing the plugin resolved the issue.

  • 4
    You can also uncomment this line: addMenuItem('Evaluate Math Expression', 'evaluate_math_expression', 'Ctrl+Y');. For me the file was in C:\Program Files (x86)\Notepad++\plugins\NppScripting\includes\Zen Coding.js Jul 11, 2015 at 0:24

The fix for me was closing Notepad++ :(

Seems that there is a plugin that uses the ctrl+y hotkey and is intercepting globally.

  • Hey anon - I don't believe Notepad++ was the culprit for me, as I made sure to close all my programs when troubleshooting this. I am a Notepad++ user, so it's entirely possible, however. My fix was to reinstall Windows, and this hasn't happened since. Thanks!
    – Jeremy
    Jun 19, 2014 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.