20

I setup backup of my Windows 8 laptop with Windows 7 File Recovery (known as Backup and Restore in Windows 7).

Backup of files runs successfully. But if I try to create system image, it fails with error 0x807800C5:
Windows Backup: Troubleshooting Options - Error code: 0x807800C5 // Details: The mounted backup volume is inaccessible.

Error details on the dialog:

The mounted backup volume is inaccessible.

Error details in the system log:

There was a failure in preparing the backup image of one of the volumes in the backup set.

I save the backup to a network location, WD MyBookLive.

 
Edit:

I tried some of the steps suggested in the various thread about this issue:

  1. Cleaned up the backup location:

    1. Removed MediaID.bin in the backup location.
    2. Removed folder <ComputerName> from WindowsImageBackup.
    3. Restarted backup resulted in the same error. However, the error dialog shows slightly different error message:

      The specified backup disk cannot be found.

      Windows Backup: Troubleshooting Options - Error code: 0x807800C5 // Details: The specified backup disk cannot be found.

  2. Performed System File Check by running sfc /scannow. It showed no errors.
    Running backup failed nevertheless.

I tried searching Google for error code but I've found no solution so far.

Update:
I submitted technical support request to Microsoft. The first suggestion was to clean boot, but it didn't help. I pointed out that I had tried all the methods from the same problem on MS Answers, and nothing had helped.

I tried to save full system image to an external hard drive, it was successful. So creating the image fails only when saved to a network location.


Note: This feature has been removed from Windows 8.1 in favor of File History. You can still create full system image yet I didn't find an option to schedule it for automatic creation.

12
  • Always try converting the error code to decimal and searching on that as well: 2155348165 - there are a bunch of hits. I haven't hit this particular error personally. – Mark Allen Nov 21 '12 at 21:59
  • 0x807800C5 = // ERROR_IOPL_NOT_ENABLED // MessageId: ERROR_IOPL_NOT_ENABLED // // MessageText: // // The operating system is not presently configured to run this application. // #define ERROR_IOPL_NOT_ENABLED 197L But i haven't found an information what this error means. But it looks like backup doesn't find the backup location (your network sahre) – magicandre1981 Nov 22 '12 at 7:16
  • @magicandre1981 But I can access the disk, it's there. I usually run full system backups via Ethernet connection rather than Wi-Fi. – Alexey Ivanov Nov 24 '12 at 20:48
  • With UAC enabled, tools runing with admin rights have isues to access network paths. Try to enable this setting and try again: support.microsoft.com/kb/2019185 – magicandre1981 Nov 24 '12 at 20:56
  • @magicandre1981 It's hardly the case: the backup asks explicitly for username and password to access the network share, and I use the full UNC path rather than a mapped drive. Backup service runs as Local System account, it has no way to see user's mapped drives. – Alexey Ivanov Nov 24 '12 at 21:04
11

I still have no complete solution to this problem although I've found a workaround in my environment.

  1. System image is created successfully when using external hard drive attached directly to the laptop.
  2. System image is not saved to network share on a Windows 7 system.
    (The same way it fails when using a Network Attached Storage.)
  3. System image is created successfully when the target has no access restrictions, in either case: NAS and Windows 7.

Workaround:
Use a network folder without access restrictions as the backup target, that is every user in the (local) network has read and write access to the folder. Windows does not require user name and password to view the contents of the folder.

If Windows asks for a password when you try to open the network folder, creating system image in Windows 8 fails. Of course, the correct credentials are provided to the Backup service, and file backup completes successfully. This feature works in Windows 7 without any errors.


My request to Microsoft support brought nothing. They made me follow the standard procedure which didn't fix the error. They even gave me the utility, wbdiag, to collect additional debugging logs. It didn't help either.

I pointed out that system image is created successfully when network folder is globally writable. Support engineer said he could not reproduce the problem when saving backup to a network folder which requires special credentials.

After that they closed my request as File Recovery feature in Windows 8 works correctly. Since NAS is not Microsoft product, they can't provide support for it. They didn't noticed the fact that saving system image to a network share on Windows 7 fails with the same error as when saving to the NAS.

10
  • The sentence that contains the word "Windows 8" does not make a great deal of sense. – Ramhound Feb 1 '13 at 20:05
  • @Ramhound Is it better that way? – Alexey Ivanov Feb 1 '13 at 20:11
  • 1
    This solved the problem for me. I would get an error in the middle until I granted everyone unlimited access. Then it worked correctly. – Steve Rowe Apr 16 '13 at 20:58
  • 2
    FYI, instead of adding EVERYONE permissions, try adding SYSTEM permissions. I was getting error 80070005 when I was trying to backup to a network share on a local drive (the only way to backup to a subfolder). Although giving full access to EVERYONE on both the folder and the share was sufficient to stop the error, such access was unacceptable. I started to narrow down the accounts, and it turns out that giving the SYSTEM account full access is sufficient to allow the backup to proceed, along with the actual user account you want to use for the backup. – Triynko Dec 15 '14 at 23:26
  • 2
    Yes, the solution of Triynko only makes sense for a local backup. Over the network, this won't work because it's not an issue on the file system level, it's on the network share level. The issue is that the client can't get past the network share authentication, so it doesn't reach the point where folder permissions are evaluated. I have the same issue and I can confirm this is a bug in Windows Backup, no matter what credentials you supply, they are not being used. I had to grant anonymous access on the share for it to work. – Martin Hansen Jun 11 '16 at 7:05
5
+100

I quote from How Windows 8's Backup System Differs From Windows 7's :

With Windows 7, you can back up any files on your computer – not only personal files, but program files, system files, and anything else. You can also create full system images that can be used to restore your computer to its current state in the future.

There’s been a major philosophical change in Windows 8. You can no longer create full system images, nor can you back up everything on your hard drive. Instead, you can only back up files in your libraries, files on your desktop, your contacts, and your browser favorites. Windows 8’s File History feature is designed to protect users’ personal files, which are generally irreplaceable. In contrast, there’s less need to back up system files because operating systems and applications can be reinstalled from elsewhere.

This seems to say that in Windows 8, Microsoft has decided for us that we no longer need system images (!).

Nevertheless, some people claim they have managed to create system image backups using Windows 7 File Recovery, as long as this was done to a local drive and not via the network.

So if you insist on system image backup (and rightly so), it is time to look for a third-party product. The Windows backup utility has since always been a weak tool with many idiosyncrasies, that I never recommended using.

There is a discussion of backup tools in Gizmo's article Best Free Drive Imaging Program and in its comments, recommending several free products. The best-noted product, and my personal favorite, is the free AOMEI Backupper Standard.

5
  • It makes sense more or less: in Windows 8 they implemented System Reset and System Refresh so that you can easily “reinstall” the system. Since the list of Windows Store Apps syncs with SkyDrive, the apps are easily reinstalled too. System Image created by Microsoft Backup has one advantage over other tools: it's can be used by Windows Setup or Recovery Tools to restore the system. I used it with Windows 7 several times. – Alexey Ivanov Nov 26 '12 at 6:14
  • 2
    @AlexeyIvanov: Microsoft just forgot that people would also like to be able to return a system disk to its current state, not only to its initial state. IMHO, MS are losing contact with power users, concentrating instead on hand-held devices and the general public. – harrymc Nov 26 '12 at 6:47
  • 1
    Biggest downside to Acronis TrueImage Home (ATIH) is that their support sucks and they don't fix errors even after years and don't follow up on error reports after initially being unable to resolve them. They also have funny ways of annoying international customers like switching your account over to a different locale. So I ended up booting the English (UK) rescue CD and was flabbergasted that my password didn't work. Until I figured out it was the keyboard layout (which the [EN] didn't give away). I like the product itself, though. – 0xC0000022L Nov 29 '12 at 16:03
  • Although this answer does not resolve the issue with System Image Backup, it provides the background on Microsoft's decision to deprecate full system images. So I awarded it the bounty. – Alexey Ivanov Dec 2 '12 at 16:12
  • @harrymc Apple is ding the very same thing -- the power user is getting the shaft from all OSes at this point... – aequalsb Feb 19 '17 at 16:54
3

Backup service runs as Local System account, it has no way to see user's mapped drives

Map the drives as "Local System account" with proper credentials and use drive letters to access your target volume. The mentioned IOPL error may be an indication of wrong permissions, such as when a login-only drive is accessed anonymously.

I have to admit that I am guessing in this case. However, it's not a haphazard suggestion: An application will include support for accessing local files in a whole lot more cases than support for accessing "samba shares" directly. So if you let the OS handle file access over the network, your backup software will be more likely to succeed.

2
  • If your guess is correct, it's enough to change the Backup service account from Local Service to Network Service . – harrymc Nov 29 '12 at 15:38
  • Windows Backup does not allow saving a backup to network mapped drive. When I configure the backup I provide the correct credentials to access the network share. And really works because file backup finishes successfully, yet nevertheless Windows Backup cannot create the system image. – Alexey Ivanov Dec 1 '12 at 9:52
0

I have a Buffalo TeraStation NAS and experienced the same issue. After providing the group 'Domain Computers' write access it worked for me.

2
  • Hi! Welcome to SU! You can be more helpful to others by providing a more detailed procedure... – undo Mar 23 '16 at 6:45
  • 1
    I agree with @Rahul, your answer is too short. Did you edit permissions of the shared folder on NAS? – Alexey Ivanov Mar 26 '16 at 22:12
0

I was facing the same error code while trying to create a system image backup in windows 10. The solution that worked for me was simply disabling windows defender.

I was able to create system images with no problem at first, my problem started after i changed windows defender settings to exclude certain folders. I believe by altering windows defender settings it altered the permissions for users on the system and denied access to the WindowsImageBackup folder on the drive in question.

When in doubt, disable windows defender.

1
  • Permissions could be an issue… Although I don't think changing Windows Defender settings changes permissions on the file system. In my case, I tried to backup to a network drive, or rather network attached storage (NAS). There's no file system level permissions available, only user-level for shared folder. – Alexey Ivanov Sep 19 '16 at 18:36
0

Seems a computer with more than one EFI partition (including on a second disk, even if external) prevents the backup from executing.

My destination disk used to be the main disk of another laptop, which prevented the backup from executing. Doing a diskpart clean to erase the disk worked.

0

I had the problem after upgrading/updating Windows 10 (creators/anniv./.. update).I had a backup on my target (networkshare) already of my Windows 10 machine. Only one image is allowed of Windows in there. I guess that after upgrade it detects that it is a different Windows (not sure), and this might be the reason why it fails.

I removed the backup from that folder and it worked again.

After searching the web I found another user who had similar:

This happens after upgrading Windows while still using the same backup target disk. The problem is the three old backup files on the target disk that you need to remove. Consider the old backup files obsolete and delete them, or move them away into a temporary folder.

  1. Datafile - MediaID.bin
  2. Folder - Windowsimagebackup
  3. Computer-name-file - Guru (For example)

Then restart your backup and find out that now it works.

Let us know the status of the issue. Your reply is need to assist you further. Regards,

Hope it helps.

(Of course make sure you have enough permissions to write on that target location… E.g. add "Domain computers" to it and give read/write permissions. Note that for example Nvidia creates also a user on your pc for its driver. I don't take this data in my backup, maybe this user doesn't have permissions on the target if you also include it in your backup… I only take my user data.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.