9

I use Tab Mix Plus, and I have the following settings set:

  • "Don't load tab until selected" in Tabs dialog of Firefox is set
  • The "Reload all tabs" in TMP is unselected
  • The setting browser.sessionstore.restore_on_demand is set to true
  • The setting extensions.tabmix.sessions.restore.reloadall is set to false

To the best of my knowledge, and everything I googled, this should suffice and prevent the autoloading of all the tabs. However, it doesn't and after opening the browser, it loads all tabs. Strangely though, when I crash the browser, it honors these settings correctly.

What am I doing wrong?

  • 1
    Maybe a conflicting extension? Disable all of them, check for issue. If issue not present, then you know an extension is causing a problem. Disable half, check again - repeat to determine the source of problem. (Do not disable one at a time since that takes a longer amount of time). – Wk_of_Angmar Nov 23 '12 at 2:36
  • @Wk_of_Angmar: Actually, I tried that. It didn't help, sorry... – Abel Nov 26 '12 at 9:57
  • I'd wondered that myself and thought to run the same test. Results: one or more of these extensions causes it not to work: Ghostery, Pin it button, Pinboard Extension, QuickJava, Tab Mix Plus, Video DownloadHelper, videoresumer, WOT. My money's on Tab Mix Plus, which I really like :( maybe there's a setting that makes them compatible . . . – r_alex_hall Jan 24 '16 at 4:21
7

At the time I write this, this is a known issue:

http://garyr.net/tmp/forum/viewtopic.php?t=15821&p=55432

The only workable solution I've found is to disable session management in Tab Mix Plus*, enable the Firefox setting to only load tabs on demand (under tools -> options -> tabs -> "Don't load tabs until selected"), and, if you still want similar (probably better) Session Management functionality, install the Session Manager extension --

https://addons.mozilla.org/en-US/firefox/addon/session-manager/ --

This extension has an equivalent setting under Tools -> Session Manager -> Session Manager -> General -> Saving and Restoring -> "Restore Tabs on Demand."

*As I've just installed the Session Manager extension, which modifies Tab Mix Plus' options interface, I don't recall exactly where to do that.

  • The tip of the week for me, thanks ! As of today (April 2014) the bug in TabMixPlus is not resolved yet. – Benj Apr 13 '14 at 14:29
  • Revisiting this problem years later, my proposed solution does not work. I can also see that the Session Manager addon really only toggles the equivalent checkmark in firefox options; e.g. the implementation of "do not load tabs until selected" in Session Manager is really just a toggle of Firefox' implemention, which has been broken for years. Boo Firefox. This problem does not happen with SeaMonkey; SeaMonkey's implementation actually works. My real solution is to use SeaMonkey instead. – r_alex_hall Jan 19 '16 at 16:47
  • The "Don't load tabs until selected" option works like a charm for me. Even with multiple windows that are restored at once. Maybe this is a TabMixPlus bug? Please try the "Don't load tabs until selected" option without any plugins. (you might need to do one restart of FF before this gets activated) – masgo Jan 20 '16 at 9:01
1

The "Don't load tabs until selected" option in Firefox is enabled by default when "Show my windows and tabs from last time" is selected. This is in Preferences > General:

enter image description here

You can change the restore behavior by going into about:config and changing the "restore on demand" option.

enter image description here

If it's not working then open multiple tabs, disable all of your plugins and restart your browser. Check if it's working. If it is then enable one plugin and restart. Check if it's working. If it is enable another plugin, restart and check again.

0

I ran this down and it turned out that the "grammarly" addon/plugin was causing the problem. Once I removed that, firefox stopped loading every single tab no matter what I told tab mix plus to do.

Hope this helped someone :)

, Mike

  • I don't use Tab Mix Plus, but today for test purposes I enabled Grammarly 8.775.1034 on Firefox 55.0.3 (64-bit) on FreeBSD-CURRENT with ninety-three other extensions enabled (total: 102, according to about:healthreport). I quit then launched Firefox and used Session Manager to restore 690 tabs across thirteen windows. Restoration was reasonably fast, I did not notice any unexpected loads of tabs. – Graham Perrin Sep 13 '17 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.