I have Ubuntu 10.04 running in a VMware player virtual machine. How do I access the SD card reader hardware from within the VM? I see no appropriate device under /dev or relevant messages with dmesg.

SD card readers (either internal or external) are usually connected via USB buses. So, all you need to do is redirect the appropriate USB device to the VMware guest.

AFAIR the default settings for desktop VMware products provide for automatic USB device connection to a guest provided the guest in question has focus. If the reader does not appear in the guest Ubuntu when you insert the card while the guest is in fullscreen please check the USB virtual device settings of the guest.

  • I didn't really see any settings for the USB controller that are relevant. Could you be more specific? – fred basset Nov 25 '12 at 18:20
  • As for adding USB devices - here's a quote from another answer on superuser: "Virtual Machine Menu->Virtual Machine Settings If you don't see "USB Controller" in the list, power down the virtual machine's guest operating system. Click "Add" at the bottom of the Virtual Machine Settings window, click "USB Controller" in the list, click "Next" and click "Finish." Then ensure it's connected to the guest and not the host: Virtual Machine Menu->Removable Devices->->Connect (Disconnect from Host)"" – Alexander Shcheblikin Nov 25 '12 at 20:12

In my case, I had to add a hard drive (choose physical and whole disk) Drive 0 is the hard drive in your system Drive 1 in my case was the SD Card There was a Drive 2 option which didn't work, so I think it was just a placeholder of some sort.

  • This answer worked for me too! Host system: windows 7 guest system: debian 7. See under windows computer management > storage > disk management. There you'll see your sd card listed as Drive n. Add a new hard disk to your VM as physical disk and select the Drive n. Reboot your VM and you should see the partitions of your sd card – wolfrevo Jan 11 '16 at 21:55

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.