3

I just migrated from Windows 7 x64 to 8, but I can't get my VPN software to run anymore : the SafeNet IKE service (installed by SafeNet SoftRemoteLT GA, used by my VPN provider) cannot start anymore.

I found that by default unsigned drivers are disabled on Win8, and that is what is blocking the driver.

The System event log tells me that the driver (apparently, C:\WINDOWS\SysWow64\Drivers\IPSECDRV.sys ) was blocked when I try to manually start the service (SafeNet IKE Service). I get the same messages for another driver, crypto.sys found in the same folder.

I tried using bcdedit to enable unsigned drivers :

bcdedit /set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit /set testsigning ON

After reboot, same error. I tried by booting into Win 8's test mode, same issue. Applying the code signing policy (Enabled, Ignore) does not help either. Running gpresult does show that the policy is applied.

Any help welcome.

  • This works fine with windows 8.1 but this or any other method does not seem to work in windows 10 – user417528 Feb 10 '15 at 16:00
4

I had a problems installing unsigned drivers in Windows 8 and the steps below worked for me.

  1. Windows Key + R
  2. Enter shutdown.exe /r /o /f /t 00
  3. Click the "OK" button
  4. System will restart to a "Choose an option" screen
  5. Select "Troubleshoot" from "Choose an option" screen
  6. Select "Advanced options" from "Troubleshoot" screen
  7. Select "Windows Startup Settings" from "Advanced options" screen
  8. Click "Restart" button
  9. System will restart to "Advanced Boot Options" screen
  10. Select "Disable Driver Signature Enforcement"
  11. Once the system starts, install the drivers as you would on Windows 7
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.