The installer is not working for my ATI mobility Radeon HD 3670 on Dell XPS Studio 16 using Windows 8 PRO 64 bits. Here are the screenshots of my ATI Radeon configuration:

Hardware configuration

enter image description here

Software configuration enter image description here

And here is the problem on Windows 8: everytime I disconnect the AC power cord, atibtmon.exe throws a runtime error as follows

enter image description here

What could I do to avoid this error? I have installed the legacy driver http://support.amd.com/us/kbarticles/Pages/catalystlegacywin8.aspx but this installer fails (when trying to install the driver).

4 Answers 4


I solved the problem by going into the CCC, into Power/PowerPlay(tm) and un-checking the "Enable Vari-Bright(tm)".

CCC Vari-Bright Screen

After clicking apply, the problem was gone.


Today I did a clean install of Windows 7 on my laptop. I never had this problem before, until today.

I went to system32 and deleted atibtmon.exe. At first it won't let you delete it because it is in use by the computer, but I have this brilliant and lovely tool, called UNLOCKER, and it unlocked it and deleted it for me. Problem solved.

  • 1
    actually, deleting it is not a solution, is a dirty fix, all the references are still there and this could give problems Dec 2, 2012 at 15:46
  • I love these tricks. I will have a go and let you know! I forgot to mention that AMD support told me there is nothing they could do to help me: "Unfortunately, you graphics adapter is based on our legacy support. Which means will not be releasing any new updates based on that graphics adapter. Amd may come out with a hot fix for this driver but as of right now there are no plans.". Dec 7, 2012 at 14:54

atibtmon.exe is the ATI Brightness Monitor.

By default, Windows will switch to a power-saving mode when you unplug your laptop. One of the power-saving features is dimming the brightness of your laptop display. It could be that the ATI driver crashes when Windows tries to automatically adjust the brightness.

Check your Windows power management settings to see if this power-saving feature is enabled on your laptop. Disabling this feature might avoid triggering the bug in the ATI driver.

Since this sounds like a problem with the ATI driver, you should send a bug report to ATI so that they can release an update to fix the problem.

  • In Windows 8, I went to Control Panel\Hardware and Sound\Power Options, and tried "Dell Recommended", "Balanced", "High performance". None worked, because after removing the power cord, the atibtmon.exe keeps crashing. I will dig extra info on internet to see if there is something that I could do. :-( Nov 28, 2012 at 14:15

Simply disable powerplay in catalyst control center. Windows have the same option inside.

On Windows 7 (or if you don't have Catalyst Control Center), go to Control Panel>>Power Options>>Change Plan Settings (whatever power play you have selected)>>Change Advanced Power Settings.

Page down to the 'ATI Graphics Power Settings' and expand that out. Under 'ATI Graphics Power Settings', there is an area for 'ATI Powerplay Settings'. Set both to 'maximize performance' from 'Maximize Battery Life'. The exception is being thrown by a conflict from ATI trying to maximize battery life vs the Operating System, so just letting the OS handle it eliminates the error when you unplug. :)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .