So I was looking for a possibility to manage the mail distribution of online shops, newsfeeds, etc. and have a nice solution via distribution groups aka. alias addresses. In example, I register an account on eBay using "ebay@organization.com" (where org.com is my company obviously). That address is an alias and can be managed on my on-premise mail server setting destination to somebody's mailbox independent from logging on to eBay - in case somebody else shall do the eBay-stuff, I can quick change the destination of that alias :-)

So far, so good - and now to the problem:
Using Microsoft Outlook 2010 and an IMAP account on our mail server, I cannot figure out how to remove that "on behalf of"-string visible in the from-field when sending a message under that ebay@organization.com address. That's quite a pity, because especially eBay doesn't accept/forward mails not coming from the registered address..

Using other mail clients (e.g. Mozilla Thunderbird), the problem does not occur so I guess it's Outlook specific.

I cannot "grant" permission to "send as", because that address is not a mailbox, but rather an alias only. Furthermore, the mail accounts are not Exchange, but IMAP!

Does anybody have any other ideas to "remove" that annoying string?

Consideration: We have to use Microsoft Outlook for some reason! :-)

  • What mail server are you using, I think the problem is there. I use a ton of different email address in Outlook and none of them show 'on behalf of'. As a test can you try sending using an external SMTP server? – snowdude Nov 27 '12 at 10:15
  • I actually use "Postfix" as MTA. But I don't think it's a server related problem, because if I use Thunderbird with that IMAP mailbox under different identity, there's just no "behalf-of" string... – Master of Celebration Nov 27 '12 at 16:00
  • Have you tried a different SMTP server just to rule out Outlook? – snowdude Nov 27 '12 at 20:16
  • Well, I tried it today with an external gmail-account (IMAP) and there is no "on behalf of"-string attached... I am confused now! In conclusion, you might be right that the problem is not Outlook-specific, but how could I send a mail under different aliases with Mozilla Thunderbird without any "behalf"-strings then? – Master of Celebration Nov 29 '12 at 8:15
  • Just had another idead: May it be, that the "on behalf"-string is only being attached by MS-Outlook if the outgoing server (SMTP) is on port 25 (no authentication required, no encryption)? Because my IMAP-account at gmail accepts TLS-connections only... – Master of Celebration Nov 29 '12 at 8:23

As a non-technical alternative to snowdudes answer, you can try to configure a separate IMAP account in Outlook which will only be used for sending emails and where you disable automatic polling. In this second account you configure the Name and Emailaddress to match the alias.

You can then select which address you are sending from by clicking on the "From" Button in the new message window.

It is not comfortable in the long run, but it should solve your problem, unless it is an server issue.

  • +1 for beacon me to the clear solution: In Outlook, if you configure an account with an email address, you can send via this address without any problems. That means if the SMTP-server does not require any authentication you can send as whoever you like to be - BUT: You have to configure an account with that identity (name / mail address) before, because if you don't, Outlook will automatically add the "on behalf of"-string to the sender of any mail sent with an identity not registered as an account before. – Master of Celebration Nov 29 '12 at 15:02

To test out whether it's the SMTP server or Outlook try telnetting to the server directly, e.g. from a command prompt:

telnet smtp.myserver.com 25
MAIL FROM:<user@email.com>
RCPT TO:<other@email.com>
Subject: Test

This is a test

That should show you where the 'on behalf of' is coming from. The other alternative is to run WireShark and filter the port 25 traffic. It will show you what text Outlook is sending to the SMTP server.

  • +1 for showing that this is not a server-related problem (as I guessed before). Thank You! – Master of Celebration Nov 29 '12 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.