I am using Ubuntu Desktop 12.04(64 bit). I have downloaded skype from the official website and opened the deb package from the terminal(sudo dpkg -i skype-ubuntu-precise_4.1.0.20-1_i386.deb) but install did not finish successfully. Now whatever I try to install I get the following error:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 skype:i386 : Depends: libssl1.0.0:i386 but it is not going to be installed
              Conflicts: skype-bin
              Conflicts: skype-bin:i386 but is to be installed
 skype-bin:i386 : Breaks: skype:i386 (< but is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Of course I tried running apt-get -f install, but when I do, I get the following output:

After this operation, 36.7 MB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of skype:i386:
 skype:i386 depends on libssl1.0.0.
 skype-bin:i386 ( breaks skype (<< and is installed.
  Version of skype:i386 to be configured is
dpkg: error processing skype:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

You can also have a look at the output from dpkg --list here.

I have also tried running sudo apt-get remove skype-bin, but again it fails with similar error.

What should I do to fix this problem?


After a lot of searching round the internet, I have finally found a solution for my problem. I directly used dpkg to remove skype:i386. In a terminal type:

sudo dpkg -r skype:i386

Hope this will save the day I wasted on this for someone.

  • +1 for finding your answer and thanks for posting back. Please accept your answer to make it clear that this is the solution (and get a little rep). – terdon Nov 27 '12 at 12:03
  • 1
    I can accept my own answer tomorrow(according to the message box). As the initial part of your comment -this is the wisdom of the ancients :) – Ivaylo Strandjev Nov 27 '12 at 13:54
  • Ahh, xkcd... :) – terdon Nov 27 '12 at 14:10
  • thanks a lot!! i wasted my 3 hours looking for this!! works like a charm :) – singhshivam Aug 8 '14 at 11:37

This two commands worked for me. There is no harm in doing this

sudo apt-get autoremove

sudo dpkg -r skype:i386

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.