last week I bought an Acer M5-481T ultraportable laptop. Everything was working fine with the laptop and battery until I decided to disassemble it to upgrade the hard drive, which was a few days after I bought it.

Since then, the laptop will only run and power on when plugged in on AC power. Despite, the battery being fully charged and recognized by the OS, when the AC power is unplugged the laptop will immediately shut off. (The only way to remove the battery is to unscrew the the laptop bottom panel).

Since then I have tried the following things:

  • Put back the original hard drive
  • Unplug and replug in the battery. When the battery is unplugged from the motherboard, the indicator does not appear in Linux Mint or Windows 7. When the battery is plugged in, it does appear in the indicators in both OS's and shows 100% which makes sense.

In order to get to the hard drive, I had to remove the built-in audio board which connects to the speakers, microphone, and motherboard. The audio board also contains the laptop power button. Also, I had to disconnect ribbon cables to the touchpad and keyboard. I tried to reconnect and disconnect the cables multiple times.

Everything else seems to work fine, just the laptop will not run on battery power. Any suggestions?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.