20

Receiving the following error:

Unable to update runtime folder sharing status: There was an error mounting Shared Folders file system inside the guest operating system.

Running VMWare Fusion 5.0.2 on OS X 10.6.8, guest OS is Ubuntu 12.10 with VMware Tools installed.

Have been unable to get to /mnt/hgfs at all, /mnt/ directory is blank. Turned Shared Folders off and then on in VMWare Fusion and received the above error.

Any thoughts what to do to fix this?

1
  • 1
    I'm having the same issue with Mountain Lion. Same Fusion build and Ubuntu version. Grrr. Dec 5, 2012 at 21:10

5 Answers 5

19

Some parts of VMWare Tools will silently fail to install unless they can compile a kernel extension. That requires a compiler and the generic headers for the current kernel, so install those:

sudo apt-get install build-essential linux-headers-$(uname -r)

And then run

sudo vmware-config-tools.pl
9

I ran into the same problem on Vmware fusion 4 a few days ago using Ubuntu 12.04 as guest (Mac OS 10.6.8 as host). The short answer (my solution, at least) is

  • DON'T install VMWare Fusion's supplied VMware tools; they don't work.
  • instead, use Ubuntu apt-get (or the Synaptic user interface) to install open-vm-tools, the open source version of the vmware tools. They DO work.
  • I had to manually mount my Shared Folders.

For example, if you have a shared folder called projects, do the following

sudo mkdir /mnt/hgfs
sudo mkdir /mnt/hgfs/projects
sudo mount -t vmhgfs .host:/projects /mnt/hgfs/projects

Once you've verified this works (ls /mnt/hgfs/projects), you can add the appropriate line to your fstab

.host:/projects /mnt/hgfs/projects vmhgfs defaults,ttl=5,uid=1000,gid=1000 0 0

Background: I spent hours trying all the solutions and advice that people described on the web for getting Fusion's "Install vwmware tools" to support shared folders. As the previous poster said, this requires build-essential, kernel headers etc. but I had no success. Finally I started probing the kernel modules and saw that vmhgfs support was NOT being loaded. Then I looked carefully at what the vmware tools install script was doing, and saw buried in a slough of messages that the vmhgfs code had compile errors. Basically, vmware's code is broken on more recent linux kernel versions; apparently this has been going on for years. I am baffled; does this mean vmware hasn't fixed these problems (or at least the latest ones)? Or does it mean vmware fusion 4 just keeps using an old version of the vmware install tools code? The thing that's really annoying is the vmware tools install reports successful installation; you really have to dig through its avalanche of messages to realize that there might be a problem with vmhgfs support. As far as I can see, the vmware tools install method is the worst of both worlds: on the one hand it requires compiling a bunch of source code, so it exposes you to all the fragility and total lack of transparency of that process; on the other hand, it tries to be an "automagic" installer, which is only OK if "it just works". Instead it fails silently and leaves you with a system that doesn't work and no usable information about where to start trying to fix it. Thank god for open source and the inclusion of open-vm-tools in the Ubuntu package manager. It works great.

2
  • Thanks. Uninstalling vmware's tools then using these instructions got it working for me on OSX host and Ubuntu 13.04 guest.
    – Jeff Allen
    Aug 21, 2013 at 19:48
  • Wow, I had no idea open-vm-tools existed. It works great on Debian unstable with no hassle at all. I'd probably recommend that people try that first before even bothering with VMware Tools.
    – jobo3208
    Feb 25, 2015 at 20:35
1

I had a similar problem but the solution was a bit different. First a bit of an explanation - Linux/Unix maps drives over directory mount points. If there are files present in a directory, they are hidden when you mount a drive over this specific directory.

In my case, I had some files there were created in the /mnt/hgfs directory of Kali before a shared folder was mounted. This prevented the shared folder from being mounted. There may be other paths to reach this solution, but within VMware settings I disabled file sharing, rebooted my Kali VM, deleted the /mnt/hgfs directory and contents, rebooted, and then re-added the shared folder within VMware settings. The /mnt/hgfs directory had been recreated and my share was visible.

I hope this helps someone.

0

Phssthpok's solution is best when it will work. VMWare Tools and other VMWare features are not updated when a new version of VMWare is released. It is extremely annoying and I wish VMWare would stay on top of this. The author of this feature has recognized the problem for some kernels (3.13) and this may be updated in v7 but in my v5 it isn't updated.

In my case it wasn't working because my kernel (3.16.0-33) doesn't work with VMWare Tools on VMWare Fusion 5. I had to use an older kernel.

The latest kernel I know works with v5 is 3.8.13 so I added this kernel, rebooted into it, reinstalled vmware-tools, rebooted again into this kernel and vmware tools now works.

Note: It isn't good to mess with kernels unless you know what you are doing.

You can find instructions to add another kernel here. Once the kernel is added choose it at boot. For some this may mean holding shift while booting but for me it was just pressing down to advanced ubuntu and selecting the kernel instead of leaving it at ubuntu. Don't forget to boot with this kernel from now on.

Any comments about which kernels work in v6 or v7 are welcome. It took me a bit just to realize which kernel would work.

0

it's 2020 and this error still pops up occasionally. But, since the error may lead you to this older post (2012), I decided to answer with what worked for me.

I have Workstation 15. I installed stuff on my guest (Kali 2020) and consequently, some basic binaries changed and required a reboot or logoff (I don't recall). Then, I noticed the shared folder from the host no longer mounted.

In VMWare, for the Guest, I opened the settings, then options tab, then shared folders. I toggled the "Always Enable" to "Disabled", and hit OK. Then I followed the same steps to toggle it back to "Always Enabled", which triggered the error "Unable to update...". Searching the web for this error message led me to this SO Question.

Looking at the accepted answer, I already had "build-essential" installed, and the linux-headers wasn't found, neither was the vmware-config-tools.pl. For me, just "Updating" seemed to solve it.

sudo apt-get update

Maybe it will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.