I have a laptop HP probook 4520s with

Core i5 M480 @ 2.67Ghz,
4Gb RAM,
640 GB HDD Radeon HD 6370m 1GB video card.

It would seem like a good stack for work, right? But My HDD has crashed after everyday walking with laptop about 1 year.

After buying my new SSD (Patriot memory - Torqx II 128 Gb SATA II) and installing new Windows 8 from scratch - it was amazing fast. But I had only install windows updates, and I feel that the speed become the same as my old HDD, after install other software for my work, it becomes so slow, so when I use my PC with old lower configuration and it really works better than my awesome laptop... I checked that TRIM and AHCI mode are turned on. So why's that?

I asked for help in Patriot Memory support, they suggested to send them ATTO test results, done, sent. Here is the response:

"Thank you very much for the attached results. Looking at the results, I can see that your SSD speed is a lot lower than it should be. Can you tell me your system specs?"

Until they checked my email, I re-installed Windows 8 to Windows 7 and it was again perfect, but the story repeats it becomes slower and slower after every installing new software. Check out some screenshots..


(sorry for the screenshot with russian TaskManager, I hope you will recognize those parameters accordingly with your english or other lang TaskManager)

So the main issue that something everytime loads the disc on 100% and the response time is jumping around 1000-3000 ms. (when something is installing - response time is ~10k-12k ms)

Why am I asking about Windows? Because I tried to install Linux Mint (x86) and It just flies. So great performance independent on how many programs I have installed. Only Windows (any 7 or 8) has this problem.

So guys, I appreciate any ideas about how to fix that and may be answers of main question - "why is it so.?"


P.S. It might be important information: I have another one partition with Linux Mint (x86) installed with Dual Boot near the Windows 8 (x64). The bootloader - GRUB. Linux works very great. So i'm not sure that it's really SSD issue.. as it works great with other (linux) OS. Right ?

UPD01: I've followed @Breakthrough's suggestion and opened DISKPART to see the partitions and they alignment offset and here is the output:

Partition ###  Type         Size     Offset
-------------- ------------ -------- --------
Partition 1    Primary      350Mb    1024 kb
Partition 2    Primary      87Mb     351 Mb
Partition 0    Extended     31Gb     87 Gb
Partition 3    Logical      31Gb     87 Gb

UPD02: Here is the screenshot of AS SSD Benchmark. It was testing about 1 hour on a 4k-64Thrd Write Step. Other steps went about ~1 min.

enter image description here

Might installing Windows 8 x86 resolve this issue, even for a little bit ?

Here is the screenshot from Clean Windows 8 AS SSD Benchmark test before Windows calculate my Windows Experience Index

enter image description here

UPD!!!!!!!! - The probles was bad SSD. They gave me a NEW one(ADATA SX900), and it just flies! Really fast. So to all having this problem - return it back to shop via warranty ASAP!!! Thanks!

  • 1
    Did you align the partition before formatting it, or verify that the SSD is indeed aligned properly after you installed Windows? You can use DISKPART to do it (type LIST DISK to find the SSD, then SELECT DISK N where N is the disk, and finally, LIST PARTITION to view a list of partitions and their alignment offset). Dec 1, 2012 at 15:48
  • 1
    please run AS SSD Benchmark and post the result here. Dec 1, 2012 at 19:55
  • 1
    Download Process Monitor from sysinternals. Leave it running for a while (but not too long as it can use an awful amount of memory) and then look at Process Summary to see if some process is continually accessing the ssd drive. This can happen, for example, if you have two anti-virus programs both scanning in real time.
    – sgmoore
    Dec 1, 2012 at 20:20
  • @Breakthrough, I've just written those commands and here is the result (Part 1 | Main | 350Mb | 1024 kb) | (Part 2 | Main | 87Gb | 351 Mb) | (Part 0 | Extended | 31 Gb | 87Gb) | (Part 3 | Logic | 31 Gb | 87Gb) | I don't know why is my "disk D:/" (those is Ext4 formatted with Linux Mint) duplicated as Extended and Logic.. Is it correct?
    – Mak
    Dec 1, 2012 at 21:10
  • 1
    that is really bad when you compare it to the review: modsynergy.com/review236.html. You use Microsoft AHCI driver. Please install the latest BIOS and Intel AHCI drivers and see if this fixes it. Dec 2, 2012 at 19:58

6 Answers 6


What you need to do, is to see what process is utilising your disk. Click on the Open Resource Monitor at the bottom of Task Manager. Then click the Disk tab and see what process is hogging up your drive, then post back here. This could be a number of issues from SSD Trash management to a rouge driver / app.

  • It seems like any of the process which is reading/writing some info. And the greater the number of these processes and the more they read / write information, the more the system slows. Especially when I install or update or uninstall something, it just react on any my click up to 30 seconds... Disk is loaded on 100% everytime, even if it uses ~0.1 Mb/s.. so any autoupdate, any logs and other background stuff is also makes it thing for a long time.
    – Mak
    Dec 1, 2012 at 22:50
  • What could you suggest basing on recent comments?
    – Mak
    Dec 2, 2012 at 16:54
  • 1
    The benchmark tells me how fast your drive is performing currently, which is much slower than it should be. It sounds a lot like a hardware issue but it it works on Linux then it must be software. How does it run when you install NO updates at all?
    – joshkrz
    Dec 2, 2012 at 20:05
  • 1
    Without any of software or drivers it just flies, i've never seen Windows so fast.
    – Mak
    Dec 2, 2012 at 20:55
  • 1
    Ok, i've found one... and the Speed on Linux (x86, Ext4) a lot better than on Windows (x64, NTFS) (. But Still less (write speed) than it should be based on technical details. So i think i should go to the Service center with this SSD.
    – Mak
    Dec 6, 2012 at 10:44

Also have same problem. I have Lenovo Z370 with OCZ Agility4 512 Gb. It was lightspeed fast on Windows7, but dramatically slow on Windows8.

I solved this problem by installing driver for Intel SATA AHCI Controller from default lenovo driver pack (D:\drivers\AHCI). Not need to make a clean install!

Now I like the benchmark results much more :) enter image description here


It was nor Windows, nor SSD problem. It was an old BIOS firmware :) I have solved the problem for my Lenovo IdeaPad Z370 with the 4acn38ww64 BIOS update.
Readme says:

4acn38ww Fixed, When Resume From S3, HDD Translating Speed Becomes Low

And the issue seems to be cured, I am very glad :)

  • yeah, this is much better result than my... btw I was installing different drivers for AHCI (from official HP website and intel..) nothing was changed. But thanks for your results! I hope that will be answer for other people who faced with similar issue
    – Mak
    Dec 10, 2012 at 8:19
  • But I have another issue... After awakening from sleep mode performance falls down again!(( After reboot I get good results again, but after closing/opening my laptop - bad result again :((Windows8 it's a fail) Dec 10, 2012 at 9:28
  • Magic of windows?... )) that's why I switched to Linux as a main OS haha
    – Mak
    Dec 10, 2012 at 14:46
  • Congrats! I've returned my SSD to the store.. they are going to give me a new one.. so I think it was definitely SSD problem. Thanks everybody for your thoughts!
    – Mak
    Jan 20, 2013 at 21:57
  • same problem with my verbatim SSD. windows performance assessment say "6.8"; but when I star an installation or even a web brower, the disk usage sais 100%! And the system become really slow
    – AndreaCi
    Jan 28, 2013 at 14:36

If you have formatted the SSD disk and reinstalled Windows 8 from scratch, letting it partition the disk, then I suppose that all partitions are well-aligned.

For Windows, check if the performance degradation also exists when booting in Safe mode. If it doesn't, then it is some installed non-Microsoft product that is causing the slowdown.

You could use the Task Manager to find the resources-hogging process.
See the article How to use Windows 8 Task Manager

You could verify your conclusions by either by uninstalling the product(s) or banishing them from startup by using autoruns.

Last, you could try to install the latest firmware for the SSD disk. As far as I could find on the weird patriotmemory website, these are the only available downloads, dating from 02/09/2012 (installation not recommended unless in despair) :

Torqx 2 TRIM Utility Beta Install Guide
Torqx 2 TRIM Utility Beta


  • Yeah, i'm not sure it is well-aligned, i just added upd01 to main post with all partitions and offsets, might you could take a look? As for the other points - i did everything you listed. Thanks.
    – Mak
    Dec 2, 2012 at 0:01
  • Did you see anything in the Task Manager, and what happens in Safe mode boot?
    – harrymc
    Dec 2, 2012 at 7:48
  • In Task Manager I see the same as in your that you posted, the one difference is the Disk every time overloaded 100%. And I can't get Safe mode because of GRUB, i tried to press F8 in the same time when choosing Windows 8 in the boot list, but nothing happened.. Might you know other method using GRUB?
    – Mak
    Dec 2, 2012 at 12:08
  • Okay, I've loaded with Safe mode and here is what i've seen: when windows loaded something started open the help window, like i was press everytime SHIFT+F1.. only closing explorer stops doing that. Could it be some virus?
    – Mak
    Dec 2, 2012 at 13:22
  • To which product belongs that help window? It might be that this is the product causing the problem. A virus is always a possibility, but it can also be a very badly-programmed program. I still suggest a reformat of the partition and very careful reinstallation of all the products, not installing anything which you don't really really need.
    – harrymc
    Dec 2, 2012 at 14:14

Select the "Open Performance Monitor" link at the bottom of Task Manager (I don't know what it is called in Russian). When that opens, go to the "Disk" tab and sort the list of "Processes with Disk Activity" by the last column "Total (B/sec)". The one at the head of the list should be the process responsible for your extraordinary disk usage. Why that particular process is using the disk so much, you can then find out from looking up its name.

  • I did so. As i mentioned in the comments it could be any process.. It just lagging if any of the process read/write any type of data. It could be the Skype when loading, then checking updates, then browser that is downloading some file or playing video. And the high score when it lags is when I install or uninstall or update some software.
    – Mak
    Dec 1, 2012 at 23:52
  • 1
    I see now; if ANYTHING is accessing the SSD, it effectively goes to 100%, even if it is only saving a simple text file. I will continue to look and think for you.
    – K.A.Monica
    Dec 2, 2012 at 0:40
  • Any Luck in looking?
    – Mak
    Dec 6, 2012 at 11:13
  • Here is my new thought: Windows may be detecting an unreasonably low bandwidth between the drive and controller and using that as 100% in the Task Manager. Try this: if you have a fresh install of Windows 7 or 8, before you make any configuration changes or install any updates, check the drive performance, then have Windows calculate your Windows Experience Index (Control Panel > Performance Information and Tools). See if you notice the slowdown after that.
    – K.A.Monica
    Dec 6, 2012 at 21:11
  • very interesting thought. the Exp Index shows 6.8 points for my drive every time. Well... I'm going to try it! thank you!
    – Mak
    Dec 7, 2012 at 0:49

Iv had this issue, just press 'windows key + R' then type 'services.msc' and locate 'background intelegent transfer service' and set it to manual/disabled and scroll down to 'superfetch' and do the same

  • Thanks! I did it as well, it was not a solution for my case. It was actually hardware problem
    – Mak
    Mar 11, 2016 at 23:39

Most of the time I get this question it is a situation where the unit was blazing fast the day of install and over the weeks/months it started to suck big time. This is usually because the person is a super-user that is writing abnormal amounts of data to the drive, causing the drive to work really hard at wear-leveling. It can also happen when the manufacturer uses crappy NAND or the drive is just getting really old and it has to fight harder and harder to fix bit level errors with ECC.

You should check if there's a patch for the drive's firmware on Samsung's website. It is pretty common for the first generation firmware on these devices... to kind of suck.

What you shouldn't do is any kind of defrag. Unlike a spinning disk that is head seeking all over the place and a defrag will help reduce head-seeks and the drive having to switch tracks all the time, SSD don't have those seek-time issues. Forcing defrags will make the drive logically shift blocks all over the place, making the drive work even harder to wear-level, and in my experience make the situation worse.

Note: What you should notice when finding SSD slow on Windows 10 (or other operating systems)? Of course, data security should be your first priority; the slow speed can be a sign of a damaged drive. Taking that into consideration, I advise you to backup existing data and recover lost data from SSD first before you try to speed up SSD.

Certainly, the most direct way to backup SSD data is copying existing data from SSD and pasting them to another drive. Of course, you can also backup data to the Cloud or by using reliable backup software (recommend: MiniTool ShadowMaker).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.