About two months ago I had done some overclocking on my CPU and GPU, which is when the problem started; I've since reverted absolutely everything I could find back to the stock settings, but the problem persists.

My system:

  • MSI 770-G45
  • Windows 7 Ultimate 64
  • AMD Phenom II x4 BE 965 (C3)
  • eVGA GeForce GTX 470 Superclocked
  • 4GB DDR3 1600 (I currently have it underclocked to 1066 because that's how the BIOS detects it, funky OCZ RAM)
  • Sound Blaster X-Fi XtremeMusic
  • 500GB SATA Western Digital WD5000AACS

The issue is, while starting, certain programs will just putter around, not accessing the disk at all and using very little (<1%) CPU, and they'll just hang like this for a minute, before starting properly. I tried to live with it at first, but it's incredibly annoying to click "Play" in Steam and then watch the computer do essentially nothing for a solid minute. I've been poking at offending processes for hours in procexp, but haven't been able to find anything useful. It looks almost like something is deadlocking inside Windows system stuff before it ever hits the actual program entry point, but it's just as likely that I can't read a Windows stack trace. What's bizarre is the consistency of it -- it's ALWAYS the same certain programs, ALWAYS right when they start, and seems to always be about the same time too.

Where do I even begin?

-E- Just remembered another place where things hang -- Services control panel. The panel comes up, then goes "Not Responding", and will sit like that, using little CPU and not touching the disk at all, for about a minute, before showing me the running services.

I also found that the behavior doesn't happen in safe mode. Steam popped up quickly.


That seems to happen a lot in Windows 7, compared to for example Windows XP. But I'm thinking it's just that Win7 is more "aggressive" in polling software, whereas WinXP just was unresponsive without the "Not Responding" added to the title bar. But I feel the actual performance is roughly the same.

Though, if it happens only with specific programs and not others, then perhaps the HDD has a bad sector in the location where the data of the specific programs is located? Try installing one of those programs to another HDD and see if the same problem persists. If the problem goes away, it's the HDD. Otherwise it's probably related to how the actual program works.

  • Then why doesn't it happen in safe mode? – roothorick Nov 29 '12 at 15:13
  • Then malware is a good candidate for the root cause, as only the bare essential drivers are loaded in safe mode, leaving out any extra processes and services that load in normal mode. Have you tried what HijackThis reports? – Juha Untinen Nov 29 '12 at 20:52
  • HijackThis didn't tell me anything I didn't already know (i.e. very unlikely there is malware present). My present plan of attack is to take the time and stress testing to set and verify a stable overclock, then reformat and start fresh. In the future, I'll take the time to create a restore point before stress testing, then revert to it afterwards regardless of whether I noticed a problem. – roothorick Nov 30 '12 at 4:37
  • Hmm, have you done memtest? There is a possibility of damaged RAM, especially if you increased the voltage more than 10 %. – Juha Untinen Nov 30 '12 at 4:58
  • I have never, ever increased the RAM voltage above the manufacturer's spec (1.65v... I'm running them at 1.63v due to motherboard limitations). In fact, I haven't bothered OCing the RAM at all -- for Phenom IIs paired with DDR3, the CPU bottlenecks the RAM, eating any possible gain from a RAM OC. This system just passed memtest a week or so ago -- the RAM should be fine. Oh heck, I'll run it again. – roothorick Nov 30 '12 at 5:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.