One of my favorite websites: http://jessiejofficial.com (yes, I'm a Jessie J Fan :')) has recently started displaying the error message "412 Precondition Failed" whenever I visit it from my home network, even when I use Tor Browser.

At first I thought that this was an issue with the whole website, however I have contacted the web developer and he has said that they has been plenty of hits within the last 48 hours. Plus, I discovered tonight that I can access the website from my phone, through the mobile network.

So it appears to just be my network as all of the devices in my house connected to the WiFi display the same error when I try to visit any page of the site. However there have been no changes that we are aware of or are noticeable to our network since the website was accessible, and I have just heard that another person in a different part of the country is experiencing the same difficulties also.

Any help/advice/suggestions would be appreciated greatly

Update: When trying to ping 'jessiejofficial.com' in Windows command prompt the request times out on all four attempts, on any computer connected to the wireless network. I can now also confirm that the same thing occurs on my MacBook Pro.


HTTP error 412 "Precondition Failed" is a server response indicating that the client specified preconditions for response in its request, and that the server could not satisfy that request.

This error is usually caused by the software loading the http resource (usually a webbrowser) so it should have little to nothing to do with your network, but is likely a common configuration setting or applet installed into the browser on all your machines. have you tried alternate browsers on the effected pages? either way, since the error is server based, but is caused by the request stream initiated by your browser, there is no good way to universally fix it. you will have to examine your browser software and determine if a plugin or security software is altering your http header. you can confirm the existence of the precondition field in your header using a protocol analyzer like WireShark.

Hope that helps

| improve this answer | |
  • Thanks for your answer. Unfortunately I have tried multiple different browsers as well as multiple different devices, including my iDevices and I have found that as long as the device is connected to my wireless network the error will appear. If I use my mobile internet connection the website loads correctly. I will install WireShark and see if there is any unusual precondition fields though – Andy Nov 29 '12 at 19:29
  • well, your router might be applying some sort of header rewrite to add an option. that kind of modification would not be apparent to wireshark, and would affect all devices as you describe. how sophisticated is your router? are we talking a 400$ Cisco, or a 49.95 DLink? – Frank Thomas Nov 29 '12 at 19:34
  • That is what I was worried of but like I say, I am not aware of any changes to the network or router at all. Our router is a DLink and it was about £150. I'm not sure on the model (I could check if you need it though) but I'd say it was capable of doing something like this. I have installed WireShark but I've never used it before so it's taking a long time for me to figure it all out – Andy Nov 29 '12 at 19:52

I actually discovered the problem and resolved the issue a while ago but I'll be honest, I forget to post here.

All I can say is that the router must have been on the way out. It could have had a virus I suppose, but either way it was misbehaving - god knows why it had targeted that one website though. We only discovered the issue accidentally on the phone to our ISP though. For a moment we had to connect directly via our hub, and just by coincidence we tried to visit the website, and what'd ya know - no problems.

So the problem was only occurring on our website because our router was at fault. We got a new router and everything is back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.