I have multiple accounts I access in Outlook, I would like to automatically add a signature to one of them (not the default one). Normally to send an email from one of the other accounts I click new email, then change the from account, however that doesn't add the associated signature. How does one accomplish this?


Insert a signature automatically

  1. On the Message tab, in the Include group, click Signature, and then click Signatures.

    Signatures command on the ribbon

  2. Under Choose default signature, in the E-mail account list, click an email account with which you want to associate the signature.

  3. In the New messages list, select the signature that you want to include.

  4. If you want a signature to be included when you reply to or forward messages, in the Replies/forwards list, select the signature. Otherwise, click (none).

Insert a signature manually

  • In a new message, on the Message tab, in the Include group, click Signature, and then click the signature that you want.

    Signatures command on the ribbon


Edit: Provided you have assigned a signature to the currently selected account, Outlook 2010 will change the signature when you select a different account from the Account dropdown. So make sure each account has a default signature set for this to work, even if the signature is blank.

  • Yes - I have configured the signatures for my second email address as you describe, but it never appears automatically. When I click new email it obviously starts of being from my default account which has no signature, when I change the from address to my account with the signature nothing changes. – Dale K Nov 29 '12 at 23:03
  • I guess it depends on which account is first selected. As this page states: "If you use Outlook as your default editor, then when you create a new message, it will always start with the signature for the default account. Replies and Forwards will, however, automatically get the signature for the account the message was received on." Apparently Word can do better. Maybe it's possible with Outlook as well with some sort of custom macro. – Karan Nov 29 '12 at 23:10
  • OK, so your answer is "you can't unless you use Word as you Editor"? – Dale K Nov 29 '12 at 23:13
  • Yes, I guess it is. If you want I'll just delete the answer since it doesn't help you much, and hopefully someone will give you a macro or figure out some other way to get this done. – Karan Nov 29 '12 at 23:32
  • No its OK, your comment clarifies things... – Dale K Nov 29 '12 at 23:43

2 years later I was faced with the same issue. The solution is to add the second mailbox as an "E-mail Account" and not as an "Additional Mailbox" of the default mailbox. Seems that it would work either way but it doesn't.


For automatically setting up your signatures to all your mail replies and forwards:

  1. Go to new message tab and select signature --> signatures
  2. Choose the E-mail account
  3. Select the signature name you want to add for new messages
  4. Select the signature name you want to add for replies/forwards

Note: the default setting would be as (none) that is the reason why the signature was not showing up in your mails.

Hope this helps Outlook 2010 users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.