I have a WD My Book 2Tb configured in RAID and connected to my mac mini using FW 800 chained connection

Mini --fw800-- MultiMediaHD --fw800-- TimeMachineHD

Recently, I had an issue with my iTunes library and try to recover it from TimeMachineHD to MultiMediaHD (it's original location).

  • When I try to recover the entire library, I get the error -36
  • When I try to recover one single file, I get the error -36 but the file is recoverd
  • When I try to recover several files, only the first one is recovered.
  • When I try to recover the iPhoto library (a package), a simple file is created!

Until now, I was using TimeMachine smoothly and didn't remember any recent changes that could have cause this.

I check the console and log files and couldn't fine any suspicious message.

Is there any additional checks I could perform ?

  • External drives aren't the only ones that fail. Have you checked the drive you're trying to recover to? – Hasaan Chop Nov 20 '09 at 0:44

Error Code -36 means an I/O error occurred. It could either be an issue with either hard drive or simply that an error is occurring along your chain. I'd suggest trying to connect one of the drives to another bus (eg. via USB, FW400 is on the same bus) or connecting to the Time Machine HD and then to the MultiMediaHD to see if that changes anything.

Personally the only times I've seen -36 errors with Time Machine were when the external hard drive was starting to exhibit issues before dying. If you are able to run a program such as DiskWarrior to check the health of the drive I highly recommend it.

  • I ran the Disk Utility analyzer without any error. The disk is configured in RAID and I didn't got any issue... I also replace all the cables and got the same error. Tomorrow, I'll try with an USB connection. – Christian Lemer Oct 5 '09 at 23:20
  • I started encountering this error, so I ran Disk Utility repair and within a few seconds it said "Checking catalog file. Invalid index key. Rebuilding catalog B-tree." The mounted disk is actually a manually-created sparsebundle image on a Windows Server 2008 shared network drive. It worked to make about 4 backups, then started exhibiting this error. I suspect that rather than a hardware failure (drive < 1 month old), the network connection to the drive was disrupted during a backup in such a way that the image became corrupt (evidenced by a lingering ".inProgress" file). It's fine now. – Triynko Sep 27 '11 at 21:18

Try starting in safe mode (shift at startup), I've recently had a similar issue with an external wd hd se. You will need both Disk Warrior 4.2 and Techtool Pro 5.0.3 (with the 5.0.4 update) and Activity Monitor to watch what is happening.

Only one thing, O.S 10.6.4 is probably not the best to use (in both normal and safe mode), You may need to go back to 10.4.11 as it achieves more than the newest mac O.S. It has taken me about a week of trouble-shooting to get any action happening… the best thing to do is try trouble-shooting in various ways… (at one stage I also had disk utility operational and Techtool Pro 5.0.7 loaded, until ttp 5.0.7 started misbehaving).

It may take a substantial amount of time (vs data importance) to solve the problem… I hope you solved your problem Chealion? it has been some time since you posted… from what I can ascertain from trial and error is that an error -36 is a mount/unmount issue… maybe I'm wrong on that one but that's how it appears. Best of Luck.


I ran the Disk Utility analyzer without any error. The disk is configured in RAID and I didn't got any issue... I also replace all the cables and got the same error.

Disk Utility does not check the disk as throughly as DiskWarrior (Preferred) or TechTool Pro.

Tech Tool Pro will check the structures, as well as the underlying media, attempt recovery of bad sectors, and more.... Basically a high powered hardware test.

Disk Warrior can also do data recovery & repair, but starts with building a complete replacement directory, from the data recovered from the original data....

Disk Utility just does basic structure testing, and basic repair.. Disk Warrior and Tech Tool Pro will be significantly more sensitive to issues and assist in repairing the disk.

  • A ran Disk Warrior (4.2) and he didn't found any issues. I only have an old version of Tech Tool Pro (4) and I'm not sure Disc Warrior data recovery & method is really safe on a Time Machine disk... – Christian Lemer Oct 6 '09 at 22:19
  • Disk Warrior v4.1x and higher are fully safe to run on Time Machine. Tech Tool Pro v4.6x are Time Machine Safe as well... (micromat.com/…) – Benjamin Schollnick Oct 7 '09 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.