276

If I install a new service then decide I don’t want that application anymore and delete it, the service is still listed in the output from systemctl as error.

Where is this coming from and how can I remove them thoroughly?

438

My recipe for service obliteration (be careful with the rm statements!)

systemctl stop [servicename]
systemctl disable [servicename]
rm /etc/systemd/system/[servicename]
rm /etc/systemd/system/[servicename] # and symlinks that might be related
rm /usr/lib/systemd/system/[servicename] 
rm /usr/lib/systemd/system/[servicename] # and symlinks that might be related
systemctl daemon-reload
systemctl reset-failed

It is possible that the systemd service 'wraps' the old style scripts in /etc/init.d, so you may want to clean that up too, but that is not where systemd services live.

| improve this answer | |
  • 13
    Be aware that there are multiple locations where Systemd unit files are stored, notably /usr/lib/systemd/system and also /etc/systemd/system/. For reference see: access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/… – Mark Edington Mar 8 '17 at 0:18
  • 11
    I had also to remove /etc/init.d/[servicename] before running systemctl reset-failed – Andrea Jun 7 '17 at 15:21
  • 9
    Right, I forgot to disable before removing the unit files. BTW, to find all unit files to remove, I inspect the output of systemctl cat [servicename]. – Amir Sep 17 '17 at 14:55
  • 3
    That worked, thank you, but I am not sure why I am made to clean up this garbage manually. – Rolf Mar 31 '18 at 1:19
  • 2
    @MarkLakata Why do we need to do systemctl reset-failed in the end? – tuk May 19 at 4:14
43

You are probably looking for reset-failed:

$ sudo systemctl reset-failed
$

From the systemd man page:

reset-failed [PATTERN...]

Reset the "failed" state of the specified units, or if no unit name is passed, reset the state of all units. When a unit fails in some way (i.e. process exiting with non-zero error code, terminating abnormally or timing out), it will automatically enter the "failed" state and its exit code and status is recorded for introspection by the administrator until the service is restarted or reset with this command.

| improve this answer | |
  • 4
    That isn't what the question is asking for at all. Why on earth has this been upvoted 17 times? – psusi Nov 7 '18 at 16:54
  • 3
    This is the only correct answer. The other ones with more upvotes and the check mark are workarounds. – Thomas Nov 21 '18 at 11:37
  • 7
    I have not read the OP's question, but this was the answer I was looking for. – CousinCocaine Sep 3 '19 at 8:41
  • This was exactly what I needed. The service apparently was removed, but the failed state was still kicking around. – Jack BeNimble Jun 19 at 17:21
31

Sounds like you uninstalled it, but didn't remove the systemd hook:

# systemctl disable [servicename]

| improve this answer | |
8

Adding on to @mark-lakata's answer and keeping in mind the attentiveness required for the rm command. [chkconfig] can simplify the process!(click here to read about chkconfig)

To re-iterate the list of commands:

  1. systemctl stop [servicename]
  2. chkconfig [servicename] off OR for newer systems systemctl disable [servicename]
  3. systemctl daemon-reload
  4. systemctl reset-failed

Note: The 1st command is optional depending on whether you want keep the service running in the present session or not (as for this question the command should be used).

The 2nd command takes care of both disabling and removing (following the symlinks) the service.

| improve this answer | |
  • 2
    chkconfig was the original command to enable/disable SysVinit services. In systems using systemd, it may be present as a backward compatibility command; but the native systemctl command is just as simple: systemctl disable [servicename] – telcoM Jul 29 '18 at 13:29
  • 2
    Okay, but the reason for me using this command is, you then don't have to explicitly run the rm command – garlicFrancium Jul 29 '18 at 19:23
  • 1
    chkconfig not found in ubuntu 16 – Nam G VU Nov 14 '19 at 10:26
  • 1
    @NamGVU updated my answer – garlicFrancium Mar 15 at 15:08
2

Removing a service from systemd :

Systemd uses unit (file to define services) to remove a service the unit have to be removed... here is a list of unit locations :

/etc/systemd/system/ (and sub directories)
/usr/local/etc/systemd/system/ (and sub directories)
~/.config/systemd/user/ (and sub directories)
/usr/lib/systemd/ (and sub directories)
/usr/local/lib/systemd/ (and sub directories)
/etc/init.d/ (Converted old service system)

Refresh systemd :

systemctl daemon-reload
systemctl reset-failed

Ghost services (not-found) :

Systemd can list ghost (not-found) services even if the unit is deleted for many reasons

  1. unit still present on one of the systemd directory
  2. unit does not exit but a file link is still present on one of the systemd directory
  3. the service is used in other unit(s)*

(*) if a service is mentioned in other unit but does not exist systemd will still list that service with the state not-found even if there is not unit file... you can search what unit is using that service with a text search and edit those units (not recommended if you plan to install that service later)


Sources: Linuxhacks.org
Disclosure: I am the owner of Linuxhacks.org

| improve this answer | |
1

A simple Oneliner could be:

service=YOUR_SERVICE_NAME; systemctl stop $service && systemctl disable $service && rm /etc/systemd/system/$service &&  systemctl daemon-reload && systemctl reset-failed

Set service to your desired service that should be deleted. E.g. service=gunicorn.service

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.