62

I have an empty folder with regular details view. File name, file size, file type columns are shown and I am happy.

Then I put some MP3 or WAV files in. Windows Explorer "kindly" changes the column types. It will show Genre, media length, Album and other metadata tags, but does not show the file size anymore. If I do not like it, I have to manually change the columns back. It is very irritating.

How can I turn this automatic behavior off?

44

You have to disable the "Automatic Folder Type Discovery" feature present in Windows Vista and later versions. (This solution is tested on Windows Vista, and probably works on Windows 7 as well. I'm not sure about Windows 8 / 8.1 / 10).

Perform the following steps:

Easy way:

Download this file and double click the REG file inside it.

Copy-and-paste way:

In case the link goes broken, copy the following lines into a new text file, save it as "resetfolders.reg" and double-click it:

Windows Registry Editor Version 5.00

; Reset and delete all saved folder customizations and settings.
[-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]
[-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags]

; Turn off Vista auto folder type template discovery. 
[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags\AllFolders\Shell]
"FolderType"="NotSpecified"

; Modify the storage space to 10000 for saving of up to 10000 folder settings.
[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell]
"BagMRU Size"=dword:00002710

Long way:

 1. Reset the folder options:

  • In Windows Explorer, click Organize -> Folder and Search Options -> View tab -> Folder Options -> Reset Folder
    • The above can also be done by removing the registry keys HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags and its subkeys and HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU and its subkeys.
  • go to Folder Options (Organize -> Folder and Search Options) View tab, and make sure the Remember each folder’s view settings is checked.
  • Close the Explorer window after changes to save the settings. Windows Vista will only remember the state of folders of the window is closed.

 2. Disable auto discovery:

  • Start Regedit, navigate to the key HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell and perform the following steps:
  • Right click on Shell in left pane, select New and then click Key.
  • Type Bags to create a key named Bags, and press Enter.
  • Right click on Bags that just been created, select New and then click Key.
  • Type AllFolders to create a sub-key named AllFolders, and and press Enter.
  • Right click on AllFolders that just been created, select New and then click Key.
  • Type Shell to create another subkey named Shell, and then press Enter.
  • Select Shell key that just been created, and then right click on an empty area in the right pane, click on New and then select String Value.
  • Type FolderType as the value name, and press Enter.
  • Right click on the Folder Type and click Modify or simply double click on FolderType.
  • Type NotSpecified as its value data.
  • Click OK.

 3. Increasing the BagMRU Cache Memory Size

  • Run Registry Editor (regedit).
  • Navigate to the following registry key: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
  • If there is not a BagMRU Size value, right click on a blank space in the right pane, then select New, and then click DWORD (32-bit) Value. Then, type BagMRU Size as the value name.
  • Double click on BagMRU Size key just created, and then enter 10000 (in decimal base) or 2710 (in hexadecimal base) as its value data.

(source)

  • 1
    Can we still enable music mode for the one folder it actually makes sense in? – endolith Mar 18 '14 at 3:13
  • 10
    I wish I could upvote this every time it has made windows less obnoxious for me. – Doug Kavendek Mar 29 '14 at 19:07
  • 1
    for me using windows 10 x64 the registry alone didn't help; I had to also reset folders – Costin Gușă Jun 19 '15 at 11:05
  • 1
    I read the comments already. Could you please explain the purpose of steps 1 and 3? In other words: Why should one do these steps in addition to step 2? – Zero3 Nov 14 '17 at 8:29
  • 2
    Copy and paste way worked perfectly for me on Windows 10. Thanks so much!! – Erik van der Neut Jul 3 '18 at 6:31
8
  1. Go to the highest level folder you have
  2. Right-click on the folder and select Properties
  3. Select the Customize tab
  4. In the top panel select "General Items" from the drop-down
  5. Check the box below that say "also apply this template to all subfolders"
  6. Click OK

This seemed not to immediately work for me, so I set everything to "Music" which did work and then set everything to "General items" again and that seemed to do the trick.

  • Based on my experience this setting is also automatically applied to new sub-folders that are created after performing the steps described in this answer. – Robert Nov 1 at 17:04
6

After the adding the Size column, or making whatever changes you like, save those settings as the default for that kind of folder. You can drag Size towards the left, so that it is easily visible. Then you can either ignore the additional columns or delete them. Then save the resulting layout as default:

First check that you aren't accidentally changing the default for "General Items". Right-click the folder, choose Properties -> Customize. Make sure "Optimize this folder for" is set to Music or Video, as appropriate.

Apply the changes: Organize -> Folder and search options -> View Tab -> Apply to Folders or on Windows 10: View -> Options -> Change folder and search options -> View Tab -> Apply to Folders

  • 2
    No, unfortunately, the "automatic folder type discovery" anti-feature introduced with Vista will override this change. Every time. – patricktokeeffe Jan 31 '18 at 20:27
1

Here is what I did, and it worked on the first try.

I am using Windows 10 64bit OS. I opened the file explorer and navigated to C drive in the main window (not the tree). I selected "Documents" and went to Properties --> Customize. I enabled "Also apply to all subfolders" and selected the format "Documents" and hit "Apply." Then I changed it to "General Items" and hit "Apply" again. Then I closed out, went to my folder (full of wave files) and the columns remained as General Items with file name, type, size, date etc.

Thanks to the guy that originally posted the solution - worked very well.

  • Does it work on subsequently added sub-folders? – dumbledad Jul 30 '18 at 13:06
-1

I have Vista, yes Vista, I know it's old, but it serves a purpose for cross-browser testing of websites...if things work on this they tend to work on other more current versions...

Here is how I over came the seemingly ever changing windows explorer column headings...

  1. I believe this is working by design, but only it only makes sense when you follow the intended user story/case

  2. I have the tool bar menu activated which contains the menu items "File Edit View Tools Help" which only become active when I first click on a folder in the left pane and then click on white space in the right pane, meaning do not click on a file or sub folder in right pane that are listed as being in the parent folder.

  3. Now get an understanding of how the tool bar menu item "View/ Customize This Folder" works. Change the "Use this folder type as a template” and check the "Also apply this template to all sub folders" Get use to how to work with this and notice how it changes the heading values. This is how you set folder template which changes the columns.

    Before the next step, remember the kind of folder template your currently viewing. Most of the time it is "Document"

  4. Now , alter the heading row by adding or removing a column heading. For example add in "Date Created"

  5. Then from tool bar menu item "Tool / Folder Options" dialog go to the "View" tab. Scroll down looking for "Remember each folder's view settings" and I also like "Launch folder windows in separate process". I then select the "Apply to Folders" button (at top of dialog) and then the “Apply” button at bottom of dialog.

    NOTE: based on what things you change one of these buttons may not be active, but be sure to select all that are active.

  6. You have now defined the template's column values.

Now repeat step 3 and see if your changes are working as required...

-1

I'm not sure if this is what you are looking for but I have been searching for everything to make my experience of editing easier. I stumbled here for one of my answers. What you described sounded a little difficult. I just went back to my folder and at the top heading of the columns right clicked got a menu choice of "size column" or "size all columns" to fit, opened and closed and it stayed. Also if yo click in the right place menu also gives choices of columns. This seemed easy to find as i have trouble searching files explorer reports not found even when it is right there.I don't know what I did to see explorer window without permissions im not sure but I got the Idea I ended up changing permissions on the C drive it's working ok.I know it's not right i dont know what trusted installer should be allowed.I own the c drive I'm not sure that is right either.Anyway do you use Foobar I added the burn file. Also figured uot how to build a cue sheet with EAC from a file and then burn. So I'll be lucky if I ever get this video edited. Good luck I get so tred of resizing columns and i need to wathc those items to keep track of the sceene,and from various folders.I do this I go looking for answers and answer myself. Thanks zapper1975@yandex.com

  • 1
    please fix this wall of text – Pierre.Vriens Oct 27 '18 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.