XAMPP keeps crashing on Windows 7. It's not Skype, I unchecked the "use port 80 as an alternative". I even changed the port in XAMPP to listen:8888, that is port 8888.

I am not using IIS (Internet Information Services).

Now I open XAMPP, then I try to start MySQL and it's fine, then when I try to start Apache, it always crashes then says,

system error. code 5. access is denied.  
access violation at address 005A in module "xampp-control.exe" read of address 00000042
access violation at address 005A in module "xampp-control.exe" read of address 00000042
  • Two things: are you running the Control Panel as administrator? Also, change your listening port to something other than 8888. Try 8007 for instance. There may be something else using 8888 that you're not aware of.
    – Ian Atkin
    Dec 2, 2012 at 23:34

1 Answer 1


I had this exact problem with Apache this morning after installing XAMPP on Windows 7. Thankfully I solved it! Here is the solution that worked for me.

  • the cause of the problem is that the Apache service is still in existence from a previous installation (even though it may not be started), and
  • the solution is to delete the Apache service and then install it again.

The specific details were as follows.

  1. Open a Command Prompt and type the following to open up the Management Console for Services:

  2. Look through the list until you find the Apache service. Right-click on the Apache service item and select Properties. Take note of the the name of the service (in my case, Apache2.4). (As an aside, also have a look at the path to the executable. In my case, the path was incorrect: it was the path to the version of Apache I had installed yesterday.)

  3. Close the Management Console.

  4. From the Command Prompt type the following code, using the name you obtained at Step 2 above. In my case it was Apache2.4 but might be different for you. This will delete the service.

    sc delete Apache2.4
  5. Reboot your computer. This step is important. The setup_xampp.bat would not run again until I had reboooted.

  6. Run the setup_xampp.bat command again.

  7. Start the XAMPP Control Panel again, and all should be well!

NB - This problem of "Access violation at address ..." was reported many times on the Friends of Apache website (see this topic), and I also posted my solution there earlier today.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .