Okay, so I have recently purchased a Sony Viao running Windows 7 Home Premium. It recently ran a CHKDSK scan at startup, which I thought was strange since I have not done anything to it recently. However, I just left it like that overnight, plugged in, since I didn't feel like waiting for it. In the morning, I checked up on it. It had a blank screen, which had the wallpaper of what seems like the Repair my Computer screen. I couldn't press anything because there was nothing to press, so I did a force shutdown by holding the power button for ~6 seconds. When I booted up, it asked me if I wanted to go to Repair mode again or if I wanted to boot up normally. I said that I wanted to boot up normally, so it went to the part where it said "Starting up Windows", with the glowing Windows logo. Unfortunately, it gets stuck here, and eventually goes to a blue screen. The blue screen says "UNBOOTABLE_BOOT_VOLUME". I reboot and the same thing occurs. Eventually I stopped doing this and went to the Repair screen.

Repair my Computer

I press F8 before the Windows splash screen, and it asks me what I would like to do. I hit "Repair my Computer", which then loads the files ("Windows is loading files..."). I then get to a screen that's blue, with some flowers on the side. This is the background image for the Repair My Computer. I wait for about half an hour, and then a window pops up, attempting and failing to detect problems. I then click the button that gives me some tools and the command prompt. None of them work except the command prompt.

In the Command Prompt

To do a diagnostics of my system status, I run SFC /SCANNOW, which tells me that there is a scan pending completion and to reboot to finish it. I do that and reboot, which brings me back to step one, since I still have the blue screen. After another hour, I get back to the command prompt, and this time I do CHKDSK D:. After about ten minutes, it tells me that the file system is NTFS. After twenty minutes, CHKDSK tells me that there are errors in the MFT mirror, the Volume Bitmap is incorrect, and there are problems with the File System. To fix them, I run CHKDSK /F D:, which fixes the problems listed. I then run the full check, and do CHKDSK /B /V /X D:, which gets stuck after processing file 24407 of 185840. I do not know what to do now. However, the BIOS is telling me that the hard drive is faulty and that I should replace it.

EDIT: I have successfully entered D: and copied my files to G: (my 1TB backup drive). Chkdsk is currently running, I am crossing my fingers for it.

EDIT 2: I have finished copying my files, and will be taking my laptop to Best Buy and then shipping it to Sony for repairs. Thanks to everyone that helped.


Since you recently purchased the machine and you haven't done anything unusual with it, I would suggest utilizing the warranty to get a replacement, or have it repaired. It sounds like a particularly bad hard disk drive is the source of your woes. You could try formatting and reinstalling the OS, but why bother when the drive may be dying slowly?

  • 2
    Yep. Return it. Even if you fix the problem, there will probably be more in the future. It is never a good sign when computers have problems when the warranty is still intact. You know, usually it's right when the warranty expires that the computer dies. ;) – Josiah Dec 2 '12 at 20:28
  • 2
    Right. When the BIOS says the hard drive is faulty, it's getting that from the drive's SMART data. That means it's defective and eligible for warranty replacement. – Michael Hampton Dec 2 '12 at 20:31

Boot to command prompt do that chkdsk /R, then fixboot and try to access D: from prompt. Then reboot to normal state.

  • I have already tried this, but it gets stuck while processing some files (as mentioned above). – user140967 Dec 2 '12 at 20:30
  • 1
    Go for solution from Ian Atkin, replace your disk. S.M.A.R.T usualy is right about this. – week Dec 2 '12 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy