Ok, I have a MSI GE70 0ND-033 Laptop with an Intel(R) Centrino(R) Wireless-N 135 adapter in it. When I had Windows 7 everything worked perfectly. I upgraded to Windows 8 and now suddenly I am randomly losing my internet connection. I will be fine one moment then the next I won't have any connection, it will show only my network listed and it will say that connection is limited. If I disconnect from my network it will say no networks are available and will be unable to even see mine anymore until I disable and renenable the adapter. Generally when it happens I just run the diagnose feature and it resets the adapter for me and tells me that the problem was that the "Default gateway wasn't available".

I have the most recent drivers - I have run Windows update and made sure everything there is up to date - I have confirmed that the adapter is windows 8 compatible... I don't know what else to do. Sometimes I can hold on to the internet for 5 or 6 hours, sometimes 5 or 6 minutes, it's entirely random.

  • I have this exact same issue on my desktop. It began after I upgraded to Windows 8. My Linksys AE1200 adapter will often have disconnecting fits or give me a "default gateway is not available" error. After I reset the adapter, connectivity is back. Tonight it disconnected half a dozen times in less than 30 minutes. I've tried switching to Google DNS, resetting my router, and reinstalling drivers. – user179017 Dec 9 '12 at 5:30

Have a look in the Event Viewer to see if there are any interesting messages.

If not, check if there are any BIOS or driver updates on manufacturer's website, or optional updates available in Windows Update. Do the same with your router.

The only download I could find on the MSI website is for the BIOS, found here and dating from 2012-12-06. Be very careful, as such an update can brick your computer.

If nothing works, Windows 8 has a problem with your computer model (not the first one to show up on our forum). The only solution left is to report the problem to Microsoft and MSI, in the hope of getting some answer, then wait for this problem to be fixed by either of them.

(Unpopular suggestion: In the meantime, downgrading to Windows 7 might be as solution.)


How did you get those drivers? Packages provided by manufacturer may not be the most recent ones.

Go to the Control Panel, then open Device Manager and find your adapter. Open its properties and on the Details tab select "Hardware IDs" from the combo box. One or more entries may be visible, but all of them will have some part in common. It will be something like this:


Write down VEN and DEV (XXXX and YYYY in the example). For my laptop those are 168C and 002B. Those are network adapter's vendor and device identifiers. When you have those, open WikiDrivers and search for ven XXXX dev YYYY (spaces instead of underscores and ampersand, insert your identifiers). If any drivers are found, grab and install the most recent ones.

Also make sure that you've updated all additional tools provided by laptop's manufacturer. Sometimes those can cause problems too.


Try disabling Power Saving Mode and those things from Intel. Set it to use only a certain wifi mode (G/N, etc). And see if that changes anything. You can do it from Advanced Properties in the Adaptor. I had those problems with my Win 7 and Centrino in my Acer Timeline X 5830TG. Also, look if you have newer drivers to download.


I had this exactly the same problem on my Notebook too. My Notebook is very similar model to your. (GE60 0ND-228XTH but same Wireless Adapter) (I posted my NB Specification here: https://forum-en.msi.com/index.php?topic=172091.0)

As you can see in the link above, I've tried many solutions I found on the Internet and none of them work (Power Option, Allow the computer to turn off this device..., All Win8 drivers from many sources and many version, Update,Downgrade BIOS/EC version)

This issue only occurs in Windows 8. Windows 7 and/or Linux are working fine, even without any additional configuration.

My solution is installing Latest Win7 Driver from Intel on the Windows 8 OS.

I've tested it (idle for a long time or sleep or heavy usage) with infinite ping (ping -t My router IP) for almost 2 weeks now and it is working so far. (No significantly consecutive ping timeout or Noticeable Internet disconnection)

This is one of my examples of my ping statistics:

Ping statistics for
Packets: Sent = 57452, Received = 57444, Lost = 8 (0% loss), 
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 223ms, Average = 1ms

I think the issue is the Win8 Driver from the Intel itself that has some conflicts with this particular device.

I hope this would help you out of this frustrating problem. :)


I had this problems for the longest time. I took my computer in and even got a new wireless card. I just recently uninstalled my Norton Antivirus protection and the problem is gone!! That is all it was. Your problem will be solved! I started using Windows defender instead. I wish I would have known this all along, it would have saved me so much time and hassle.

  • Your reply is more suitable for a comment than for a proper answer. Please refrain from doing this until your reputation allows to make comments, thank you. – MariusMatutiae Jun 27 '15 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.