I am using my Asus UL30JT with Windows 8.

I installed Elan Smart-pad driver It basically works just fine, I have all the gestures and stuff. However, to adjust the settings I have to launch regedit.exe, because the window appears to be broken. Under Mouse -> Elan Tab -> Options I see this:


Do you know how to fix that? Also, if you have a similar program, can you at least send me screens of what I can change? As I said, I am editing registry right now and I need some guidance what I can actually do :)

@HaydnWVN I am using registry, because it is the only way to change something. for example - make the area, where gestures react, a bit smaller. Because othewise, on my rather small touchpad I was always triggering random gestures. I fixed that by changing the field of effect to something a bit smaller.

I found it myself.

@Karan Yep, I installed and reinstalled everything, over and over again. Many versions, older, newer, Asus original, only Elans. Sometimes I even forced drivers from completely unrelated, newer laptop models. The best I got was to launch that settings window, however it was a bit faulty driver and it disabled almost everything. Even Microsoft Driver for PS/2 mouse was better.

  • Explain why you are going into the Registry to change settings and why/where you found this information. – HaydnWVN Dec 3 '12 at 15:41
  • Have you tried reinstalling the driver and associated software? – Karan Dec 4 '12 at 22:11

Go to the registry key HKEY_CURRENT_USER\Software\Elantech\SmartPadDisplay and change all values to 1. This fixed the problem for me.

  • This did not change anything for me, even after a restart and confirming the values had been set to 1. – Jess Riedel May 21 '14 at 4:51
  • Worked for me on ASUS N73S, with Windows 8.1, Elan Touchpad – Nikola M. Oct 22 '15 at 20:10

Get the driver from Samsung. It worked. It uses a different UI.

  • This is an old version which does not support Windows 8 gestures (e.g. swipe from right edge to get the charms bar). However, it works perfectly with the hardware and the configuration ui works. – Michael Tsang Dec 16 '12 at 15:12

protected by Community May 26 '13 at 22:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.