I'm running VirtualBox 4.2.4 on a Windows 7 x64 host. I installed a Xubuntu guest system. The VM has network access through NAT. VirtualBox is configured to act as DHCP server (setup by default) and listens on The IP address of the host on the LAN is, the router is

So, after I installed Xubuntu, everything just worked, no problem connecting to the internet. I didn't configure anything.

However, I now want to share a folder in the Xubuntu guest and access it from the windows host. But when I look up the IP address of the guest it is I don't understand where this comes from, I have no network with that address block.

I installed dhcpdump to have a closer look and sure enough, the DHCP request is answered by I have no idea where that comes from.

I tried to traceroute this mysterious IP but that doesn't seem to work, just prints asterisks (but it seems that's another problem, it doesn't work with e.g. google.com as well).

I also tried to scan it using nmap but I'm not sure what to make of the result:

135/tcp   open  msrpc             Microsoft Windows RPC
445/tcp   open  netbios-ssn
554/tcp   open  rtsp?
2869/tcp  open  http              Microsoft HTTPAPI httpd 2.0 (SSDP/UPnP)
5357/tcp  open  http              Microsoft HTTPAPI httpd 2.0 (SSDP/UPnP)
9000/tcp  open  cslistener?
10000/tcp open  snet-sensor-mgmt?
10243/tcp open  http              Microsoft HTTPAPI httpd 2.0 (SSDP/UPnP)
49152/tcp open  msrpc             Microsoft Windows RPC
49153/tcp open  msrpc             Microsoft Windows RPC
49154/tcp open  msrpc             Microsoft Windows RPC
49155/tcp open  msrpc             Microsoft Windows RPC

Device type: printer|switch|remote management
Running (JUST GUESSING) : Samsung embedded (87%), 3Com embedded (85%), Dell embedded (85%), Xerox embedded (85%)
Aggressive OS guesses: Samsung CLX-3160FN printer (87%), 3Com SuperStack 3 Switch 4300, Dell PowerEdge 2650 remote access controller, Samsung ML-2571N or 6555N printer, or Xerox Phaser 3125N printer (85%)
No exact OS matches for host (test conditions non-ideal).
Network Distance: 1 hop
TCP Sequence Prediction: Difficulty=17 (Good luck!)
IP ID Sequence Generation: Incremental
Service Info: OS: Windows

I don't get it. What's behind this IP address? How is it possible that it answers DHCP request in the VM guest?

I assume everything will work fine when I manually configure the correct DHCP server address but I'd really like to understand what is going wrong here and where this mysterious IP comes from.

migrated from serverfault.com Dec 5 '12 at 13:14

This question came from our site for system and network administrators.


10.0.2.x/8 is the default address block for inside a vBox NAT Network. see the section entitled "Network Address Translation" here: http://www.virtualbox.org/manual/ch06.html NAT defines an internal address and an external one. the external one is the, and the internal range is 10.x..y.z/8. the NAT translates requests for ports on the external interface to hosts and ports on the internal so that maps to for instance.

in order to share the folder, you must first forward the port through the vbox Nat. there are instructions in the link above under the title "Configuring port forwarding with NAT".

then once you have everything configured correctly, you should be able to access your file share by going to

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.