1

I'm running CentOS 6.3 x64 in CLI. When I try to install guest additions, everything seems to work. Except "Installing the window system drivers" returns "[FAILED[ (Could not find the X.Org or XFree86 Window System" which I assume is because it's a CLI and doesn't have a window system.
After restarting, the guest additions do not seems to be installed, as the window will not resize.
I have tried a yum update and a yum upgrade but, to no avail.

1
  • the guest addition auto-resize only works on a XWindow system, it won't work if you only have CLI. To change size of CLI, you should edit your kernel parameters in grub config. Dec 7, 2012 at 2:03

2 Answers 2

2

This is a simple fix, first install dependent drivers:

yum -y install xorg-x11-drivers xorg-x11-utils

and re-run the guest additions script

1

@user1836766 I did what I directed. However, after installing another message came up:

VBoxClient: error while loading shared libraries: libXt.so.6: cannot open shared object file: No such file or directory modprobe vboxguest failed

so I solved the problem like this:

$ sudo rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
$ sudo yum install perl gcc dkms kernel-devel kernel-headers make bzip2
$ reboot
$ mount /dev/cdrom /mnt
$ cd /mnt
$ ./VBoxLinuxAdditions.run
$ reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .