I have a Win7 guest on VmWare Workstation 6.5 running on another Win7 that is on a notebook with wireless network. Seeking this same problem on web pages I do not found and answer for my problem not even a problem like mine.

I tried Bridge or Nat, changing windows network adapter confs on the two OS, and change settings on Virtual Network Editor too. But none worked.

My notebook ip is something like, gateway is Even setup virtual adapters to this subnet and this configs on DHCP not worked. My great doubt is what type of connection to use on VM (Bridge, NAT, etc...) and what adapter to change (VMNet0, VMnet8) or create a new one.

I don't know how to combine those options to make it works.


I use Custom VMnet8(NAT) on the Virtual Machine.

In the Workstation "Virtual Network Editor" set

Tab NAT/ VMnet host = VMnet8.

Tab DHCP/ Virtual Network = VMnet8

Quit and restart Vmware after Workstation network setting changes; if not sometimes they do not work properly.

  • I tried this, but didn't work. – DontVoteMeDown Dec 7 '12 at 15:40
  • of course VMnet8 has to have the DHCP service enabled on the "virtual network editor" ... If it doesn't work tell us what the client's ipconfig parameter returns – Pat Dec 7 '12 at 16:11
  • Nope. Ipconfig returns this: ipv4: and gateway, that's is our router. – DontVoteMeDown Dec 7 '12 at 16:45
  • I consider your internet comes from the wireless connection, then there's no way the guest OS could ever hit your wireless DHCP service for getting its IP. Are you having some "bridging" enabled?? I recommend you starting over reading the settings on my answer carefully. – Pat Dec 8 '12 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.