5

In Gnome 3/Nautilus (in Fedora 17), the keyboard shortcut for moving a file to trash is ctrl + delete. How do I change it to just delete?

3

Kache’s solution worked once, I think, but that seems to have changed. What worked for me was to open ~/.config/nautilus/accels, where the second line said ; (gtk_accel_path "<Actions>/DirViewActions/Trash" "<Primary>Delete"). The semicolon is a comment symbol; delete it and also remove the <Primary> part. Finally make sure to really restart Nautilus. (Don’t forget about a possible second instance that you may have open on another workspace like I did.)

Thanks to Kagu and dmoebius for this.

2
  • 1
    This worked for me on Debian 8 Jessie – aaaaaa Nov 30 '15 at 2:10
  • I had to do something similar on a fresh install of Ubuntu 16.04.3 to restore the delete key moving files to trash... Wow, what a regression. – Algomorph Sep 22 '17 at 14:37
1
  1. In terminal:

    mkdir ~/.gnome2/accels # without this directory, the change won't stick

  2. Then: gsettings set org.gnome.desktop.interface can-change-accels true

    Alternatively:
    Run dconf-editor, navigate to org.gnome.desktop.interface and check can-change-accels

  3. Open Nautilus, select any file, go to menu Edit, and highlight Move to Trash.

  4. Hit delete to clear the old shortcut, and hit delete again to set it to delete.

  5. Then in terminal:
    gsettings set org.gnome.desktop.interface can-change-accels false

    Alternatively:
    Uncheck can-change-accels in dconf-editor

1
  • Kache's instructions work successfully on Debian Wheezy. – Michael G. Noll Nov 30 '13 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.