to cut the story short: there are two symptoms I can observe. First every time I turn my laptop on, the clock resets back to 1/1/2009 12:00 AM. even if I don't disconnect my laptop from a direct power source. and second, while the computer is turned on and I'm working with it, sometimes the clock jumps to a random time in future or past. These jumps can be as small as few minutes or as large as dozens of years! I know the problem is not BIOS battery since I've changed that battery myself, but it didn't help at all. Besides, while the computer is connected to power source battery should be practically useless, right?

Here is the full story: I've got an HP Pavilion-dv6-2020ev laptop. about a month ago, I've tried turning on my laptop, but without any previous alters, it didn't turn on. since I don't have access to any authorized HP care center, I've asked an unauthorized technician to fix it. After about 3 weeks he claimed the laptop was fixed. and he said he had changed "Graphics chip", which I think he either meant south bridge or GPU. I got the laptop back, but I still couldn't turn the laptop on. I've changed the adapter since I've suspected there was with that part. Using the new adapter, I could turn the laptop on. I've got a dual boot Windows/Fedora on my system, and I was shocked when I saw grub countdown timer didn't advance, needless to say, neither windows nor fedora couldn't boot. After fedora checking boot log, I saw OS was complaining about HW_CLOCK. So I went to check what was going on in BIOS and saw the system clock was completely stopped. It was fixed exactly at 1/1/2009 12:00 AM. I've changed the clock to correct local time, and after that, the clock started to move forward. After that, both Windows and Linux had no problem booting, but I noticed a new issue. Every time I turned my laptop on the clock resets back to that mentioned time (I think it's the same year as my laptop was manufactured). even if I change the time directly in BIOS and save/quit BIOS menu, the time is not stored after restart caused by BIOS configuration changes. First I've suspected there is something wrong with BIOS battery, but changing it had no effect at all. so I suspect there is something else wrong with my laptop or (to be precise) its motherboard. Now I'm wondering if you could give me any hints where to look for potential problems.

Side Note: system doesn't seem to forget other BIOS settings which makes it even less probable that the Battery is the problem.

  • It sounds as if the clock chip got damaged. This happens quite a lot with a few years old systems.
    – Hennes
    Sep 11 '13 at 15:44
  • @Hennes That's the only thing I suspect, but how can I fix it? I mean should I completely change the south bridge? or is there any other way to fix it?
    – Ali1S232
    Sep 11 '13 at 19:06
  • I doubt it's worth 'fixing' - you're looking at a whole new motherboard to fix something like that, or trying to reflow it, which likely isn't a good idea either. Apr 20 '18 at 17:32
  • Have you identified where the RTC chip is located? If you have a fine-tipped soldering iron you might be able to find that part on Digikey and try replacing it. Could also be the crystal.
    – A. Kendall
    Apr 20 '18 at 17:51

I'm not sure if anyone else having the same issue, but after something close to two years, the issue was fixed without me doing anything. In the meantime, I just had a script running which updated the system clock every minute as a temporary (permanent) fix.

I've replaced that laptop about two years after the issue was solved, and after a certain time, it never bothered me. To this day, I still don't have a clue what went wrong or how it was fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.