I have two laptops connected by ethernet cable to a simple home router.

HP Pavilion dv6000 runs a Serva server on Windows 7.

ASUS x71q has a faulty DVD drive, and the F9 restore key does not work, so I've set up a Serva TFTP-server in order to restore Windows Vista on the Asus over my home network.

The Asus have some self-inflicted HDD error. I made a mistake with fdisk and set the HDD active partition to something wrong, and now I only have 'Grub rescue' on it.

The Asus has a dual boot of Windows Vista and Ubuntu 12.10. It still has the recovery partition, but without a working F9 key I can't reach it - and I was trying in a roundabout way to reach it by reinstalling Vista from PXE.

I have set the WIA_WDS_SHARE as accessible to anonymous login in the Group Policies. I only reach the ServaPENet login dialog box where I am expected to write in a user and a password.

However, I do not know what to write in this box as I have tried all the account names and passwords of the HP Pavilion, and I've tried all the account names of the Asus.

Where on the dialog box it says "Connecting to Serva's Windows Installation Asset, I get an added "Error!" This is further detailed by "Error: Connection failed with error 0x35". I have no idea what this means.

I hope someone could guide me a little and explain what I am missing. I can't see a way to set a password/user for the actual share - and I can only see a way to set accounts that can access it through the advanced sharing button.

Apologies if this is a bit vague. I'm at a point where I feel I know so little that I don't know what specific questions I should ask.


About the crash, that crash only happens when Serva “non-Supporter” times out; 60 minutes of use. It is already fixed on v2.1. Serva (as far as I know) does not crash while working…

Error 0x35 is a “net resource not available” error that can be triggered in several ways. 1) Network connection unreliable. 2) NIC not working properly 3) Net driver not working properly (even if there are no errors) 4) WIA_WDS_SHARE running on a very busy/slow server.

If your network is ok I would check the NIC and specially its driver. There are reported 0x35 errors when installing Vista while the same system installs Windows 8 correctly. On all those cases replacing Vista Boot.wim with Windows 8 Boot.wim, erasing the Vista’s SERVA directory and restarting Serva does the trick. Not really a Serva’s fault.


Kinda old post but, I was just trying the same thing today.. And for the reference, it turned out to be my antivirus' firewall was turned on.. So if you came here to this old post by searching about that problem (like me), check your firewall as well :-)


please read the howto on serva's page http://www.vercot.com/~serva/an/WindowsPXE1.html

4.5- Creating MS Network Shares.

While the initial net install stages use TFTP for transferring the required components there's a moment when the install process requires accessing the rest of files by using the services of a Microsoft network share. RIS and WDS OSs require different type of share (remember they both -RIS & WDS- belong to different generations of software).

4.5.2 When installing WDS OS's : 
Directory WIA_WDS has to be shared as WIA_WDS_SHARE (read-only). This share should not be     a "Null Session Share" and of course it will require a valid username and password set in order to remotely gain access to it from a booting client.

Please create only the shares you need. i.e. if you are not installing RIS OSs then you should     not create WIA_RIS_SHARE.

check if you can actually connect to that shared resource

  1. It is better if you do not set WIA_WDS_SHARE as anonymous; set an user and a password.

  2. If you correctly set the share you should not get the error 0x35.

If you still get it that could mean your network driver is not really performing well, or Serva machine is extremely busy, or your network unreliable.


Also check your networking and share center settings on Win 7 and if it has password protection enabled then uncheck it.

Note that this protection has nothing to do whether you have or have not password in your Windows account.

  • 1
    Your answer is not correct for installing WDS assets (Vista and up); in order to access the WIA_WDS_SHARE you must use an user "with" password. On the other hand when installing RIS assets (Win 2000, XP) WIA_RIS_SHARE must be a "Null Session Share" (RIS requirement) only on this case (and just because RIS is today really old technology) your answer is valid
    – Pat
    Nov 5 '14 at 15:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.