I tripple boot my computer Windows 8/Linux/OSx with the default load as Windows. Every once in a while, I will start my computer, walk away, and then realize I wanted a different os than Windows, so I'll hold down the power key and shut down the computer (Windows 8 takes eons to load, and then you have to log-in to shutdown the computer, which takes even longer, 2-3 minutes on my desktop).

Windows, of course, thinks that it failed to start up. In previous version of Windows, this was no problem. I would just cancel out of boot repair/disk check, and it would start up fine since there was really no boot problem.

In Windows 8, however, there is no way to cancel, so it attempts boot repair, but fails, either a) because there is nothing to repair, or b) because I have no admin account on the machine.

Which leads me to the next problem. I can't access anything in the trouble-shooting, like command-prompt or the boot repair menu because it says "there aren't any administrator accounts on this PC," even though my user account has admin rights over the machine (though, I don't think the Windows "admin" account is enabled for security reasons).

Anyway, I can't enable the admin account because I can't get to command prompt. I can't get to command prompt because I can't enable the admin account. I can't stop startup repair because I can't get to command prompt. I can't boot the computer without disabling startup repair.

I upgraded downgraded Windows 8 overtop of Windows 7 so I have no install disk to use.

Any suggestions? (other than deleting that partition and just booting up into Linux and OSX from now on?)

Here's the error message I'm getting:

You need to sign in as an administrator to continue, but there arent any administrator accounts on this PC

  • 1
    "Windows 8 takes eons to load" - Strange. Due to its kernel hibernation feature Win8 is by far the fastest booting Windows version I've ever used, even without an SSD. – Karan Dec 11 '12 at 23:31
  • Ha! hardly. I have a 3.5 GHz quad core machine with 24 GB of RAM. Each OS is on a different hard drive and I can tell you that OS X takes seconds to load, as does Linux Mint, but windows takes at least 1-2 minutes to load the OS and then another 2 minutes or so to load all the os services before it's finally usable. – Jason Dec 12 '12 at 3:01
  • Weird. Using a SATA 6.0 Gb/s 7200 RPM HDD I can get to a usable desktop from a cold start in less than half a minute (no multi-booting though). Anyway, none of this solves your issue. – Karan Dec 12 '12 at 3:15
  • Between the lack of admin account and the weird slow boot times, and the fact that it was an upgrade I'd reinstall Windows 7 and then if you really think you need Windows 8, upgrade it again. Windows 8 is NOT normally slow to boot, so something has to be really wrong with your install of it. – Mark Allen Dec 12 '12 at 7:15
  • Windows 8 isn't slow to boot if a) your bios is configured for quick boot, b) if you have the right bios firmware, c) you install windows 8 on a fresh hard drive and don't upgrade from 7, and d) if you have no peripherals plugged in. Then after login, there are tons of services to load. – Jason Dec 12 '12 at 14:44

Fixed it. I opened up my computer, unplugged the other hard drives, and boom, it worked. Startup repair worked.

It did this to me on install. Why does Windows 8 assume it's a) the only drive on the computer? and b) that it is the boot drive??? Windows 7 never did this.

  • 1
    Oh yes it did. Windows 7 service packs fail to install if you merely rearrange BIOS boot order of disks (eg chainload from grub bootloader to the Windows partition, which is active on a second disk). Even worse, recovery points wouldn't create right. Startup repair probably is exercising the same logic. – Ben Voigt Dec 13 '12 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.