Out of ideas on this one. (Running Windows Vista.)

I have a program that accesses the internet to retrieve financial market data. One day it tells me that it can't log in -- timeout error. I check the documentation and it says must have a working copy of IE browser installed. I check IE (have IE-9) and sure enough -- it just spins. No error message, not timeout, no 'try later' -- just spins -- as far as I can tell, indefinitely. Any page, any address. Even access to a localhost site just spins.

Chrome works fine. So does another program I have that fetches market data. Windows 'diagnose and repair' says my internet connection is working fine.

I tried uninstall/re-install of IE. Same spinning. I tried to install Windows Updates, and guess what? I can't. I comes up with error 80072efd; checked documentation for the error and it says

I should check firewall blockage.

Thing is, the only firewall I have is Windows Firewall, and obviously it wouldn't be blocking Windows Update. In contrast, Windows 'Help' in all programs has no problem accessing the Internet.

I had a filter on the internet connection, and this was updated just prior to first appearance of the problem. But I uninstalled the filter entirely (official, with passwd from the company's service rep) -- and no difference.

I'm guessing that a high level Windows network service file is corrupted -- used only by MS programs and their ilk, but how do I find it? I'd like to avoid having to do a clean install of Windows.

Much obliged for any insight. IG

Ramhound -- Thanks for reply. I'm familiar with virtual machines as in e.g. JVM or an emulator for an alternative architecture or (theoretical) Turing Machine equivalence. But I'm not familiar with the way you're using the term. Please clarify -- what one needs for this VM 'test' and why you expect it will provide an advantage of insight into the problem. And what sort of 'configuration issue' are you referring to? IG

migrated from stackoverflow.com Dec 12 '12 at 10:59

This question came from our site for professional and enthusiast programmers.

  • Verify the behavior in a virtual machine. If it happens there then its a configuration problem, if its not, the reimage the system in question. – Ramhound Dec 12 '12 at 15:43
  • Hi I Gottlieb! Please register your Stack Overflow account and use the same user details to log in here on Super User. This way you'll gain control of this question again, can comment, etc. // @Ramhound, see update by the OP – slhck Dec 13 '12 at 10:13
  • When I use the term "Virtual Machine" I mean a program like "Virtual Box" which allows you to install an operating system and roll back changes to the virtual machine. This the behavior you describe happens without any changes to the operating system after its installed you know its not the system but the filter, if it doesn't happen, you know you need to reimage the system that isn't working. You can find Virtual Box here virtualbox.org – Ramhound Dec 13 '12 at 12:09
  • Ramhound -- thanks for clarification. After looking up Virtual-Box, I'm realizing I should have tried the basic System Restore. I seem to have missed the obvious. Yes? – I Gottlieb Dec 16 '12 at 10:57
  • In case this is useful for others w/ similar issues -- I resolved the problem very simply -- just reset the winsock catalog (Command Line: netsh winsock reset). Note that this will require re-installation of any 3rd party Layered Service Providers you may have. – I Gottlieb Dec 19 '12 at 7:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.