45

I'm using Windows 8. When I try to use SimpleAssemblyExplorer Windows pops-up a message, and doesn't allow me to run that application. I tried to run it with the compatibility options; Windows 7 & XP, neither worked.

Since SAE projects seem to be inactive, there is no way to test the new version.

How can I get rid of this message and get the program to run?

The text reads "This app can't run on your PC. To find a version for your PC, check with the software publisher."

Here is a screenshot:

Windows 8 nag

4
  • Please post a screenshot of the message in question. There isn't any reason this application should not work on Windows 8. This question has nothing to do with the modern user interface so I removed that tag.
    – Ramhound
    Dec 12 '12 at 12:37
  • Well, I found the reason, that It seems, I have x64 app, which don't have any clue on the name. I downloaded x86 and it worked fine.
    – Jones
    Dec 13 '12 at 5:24
  • 1
    I think you should post your solution as an answer, and restore the screenshot in your question. This to help anyone else with a similar issue. Dec 13 '12 at 5:39
  • 1
    Ok; I'll do it.
    – Jones
    Dec 13 '12 at 8:45
38

In my case, by mistake I had overwritten the exe file with a 0KB file. And trying to run this caused the same exact message

8
  • 3
    The same in my case, except I haven't figured out what caused the zero byte file - was the output of a failed Visual Studio build attempt I suppose.
    – RedFilter
    Jun 19 '15 at 13:30
  • 2
    I ran a batch file that i copied from the command prompt, with the extra C:\....> at the beginning apparently this copies a new 0KB file over the existing one. This error message is the worst, should just say invalid exe or something.
    – TechnoCore
    Nov 3 '15 at 18:24
  • 1
    Same thing happened to me, but with winhttpcertcfg.exe. Apr 7 '16 at 23:06
  • I was sure this didn't apply to me, but it made me look and sure enough this was it.
    – chrismay
    Jul 26 '16 at 18:22
  • It's uncanny how many people this has happened to. There must be something somewhere that's causing this. A bad example in some documentation or something.
    – BenCr
    Nov 21 '16 at 13:50
20

Well, the above error message (shown in the screenshot) is not very detailed. However, the problem is: using a different architecture than Operating System architecture. In my case, I wanted to (or tried to) launch the x64 executable whereas the OS is x86.

To solve the issue, I had to download the x86 version of the same software (the app), and that worked fine. The confusion arises because Windows 8 doesn't provide much detail for troubleshooting the problem.

3
  • 1
    Feel free to accept your own answer, as to help others that are looking for a solution.
    – pleinolijf
    Dec 13 '12 at 9:05
  • 1
    I also had this happen when running a 64-bit program on a 32-bit machine. Gotta love 'em "friendly" messages which fail to tell you what actually went wrong.
    – RomanSt
    Feb 24 '13 at 11:25
  • Any particular reason I'd be getting this on an x64 system for what I thought was a 64-bit app? (Maybe it's the old itanium 64 bit?)
    – ebyrob
    Oct 29 '13 at 7:51
8

Corrupted installer is another cause for this error message. See Corrupted files are the cause of Windows 8 "This app can't run on your PC" error.

3
  • 1
    That was the problem for me with Java 32 bit install. Thanks ! May 7 '14 at 10:13
  • 1
    Same, the JDK 64 bit installer was corrupt. Just had to download again. This kind of thing makes you question your sanity.
    – nialsh
    May 8 '14 at 19:26
  • My issue too. Try downloading with Internet Explorer. It allows you to resume download, whereas Firefox silently dropped the ball.
    – Neolisk
    Apr 9 '15 at 13:12
4

A zero-length EXE file will also cause this error.

1
  • This was my case on Windows Server 2016. What a bizarre issue. Sep 13 '17 at 16:12
3

I'm not sure if anyone else has pointed it out. This might be also caused by you running a 16-bit executable file on a 64-bit OS. Like in my case here for an old software setup. You can usually get more info from the Windows Event Log:

enter image description here

0

Hmm, compatibility settings usually fix that. For anyone in the future, if the problem still persists, there are a couple more reasons why the application might not launch. Heavy disk fragmentation, admin access, and malware can also be the causes. Defragmenting your disk and doing a scan with anti-virus software helped me solve an issue in the past. And yeah, as people mentioned, architecture differences can be a pain in Windows. Hopefully, this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.