I have installed 7-Zip on my machine and associated it with serveral archive file types.

When double clicking an archive (so far I have tried .zip, .7z and .bz2 files), a message box pops up telling me that 7-Zip cannot open this file as an archive. dialog screenshot

However, when I right click the file and select 7-Zip->Open as archive, it works just fine.

All the file type are associated to 7zFM.exe, the 7-Zip File Manager (as opposed to the 7-Zip GUI or command line).

  • maybe the file is corrupted? – picakhu Dec 12 '12 at 14:04
  • 1
    No, it happens on every archive file. And I can always open them using the context menu. – Chris Dec 12 '12 at 14:29
  • Did you try an uninstall and reinstall of 7zip? – Karan Dec 12 '12 at 18:03
  • @Karan Yes, twice already. – Chris Dec 17 '12 at 7:26
  • I had this issue to open a jar on Windows 10. I solved it by chosing (in "open it with") "7Zip FM.exe" instead of "7zip GUI.exe". – JinSnow Dec 12 '20 at 15:47

The problem is that the default is opening with 7zG (gui) while it should open with 7zFM (file manager).

You can change this using a program like DefaultProgramsEditor

Good luck.

  • This worked - now double-clicking an associated *.zip file opens up the 7z graphical interface as expected. – Aniruddha Varma Jan 16 '16 at 8:09
  • Only this one worked for me. :) – Sourav Ghosh Aug 18 '16 at 20:44
  • +1 Still valid as of October 2020. – Sabuncu Oct 23 '20 at 16:55

You could try to reset the associations from within 7-zip File Manager. One thing to note, if you are using Windows 7, you need to run 7zFM as administrator so it can set the changes.

  • Thanks, this is a good idea I hadn't thought of yet. Unfortunately, this didn't fix it. – Chris Dec 17 '12 at 7:34
  • Worked for me with 7Zip 18.05 and Windows 10, with the menu Extras/Options on the first tab by setting the desired file types manally using the '+' button. – malamut Jan 2 '19 at 20:29

Some registry keys were pointing to an x86 version of 7-Zip, which for some reason can't handle being invoked directly on this machine. I am not sure whether this is a bug in the x64 version of 7-Zip or whether a x86 version was installed on this machine before and didn't uninstall cleanly.

The following registry keys referred to the Program Files (x86) directory. Changing those to refer to the Program Files directory fixed the problem.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.