I have Fuduntu 2013.1 (Best of Fedora and Ubuntu in one OS) installed on my Gateway netbook, along with a couple of other distros including CrunchBang.

All my distros have a shared /home partition. I originally thought this was a good idea, but now I see, as 2F4U mentioned (http://ubuntuforums.org/showthread.php?t=2051212), that all the config files stored in ~ start to conflict across distros. But now it is too late to change my usernames or mount it as /stuff (I think. If this is possible, let me know).

So, my main remaining problem is that Dropbox keeps generating the following error:

Starting Dropbox...Traceback (most recent call last):
  File "<string>", line 6, in <module>
zipimport.ZipImportError: can't decompress data; zlib not available
^CTraceback (most recent call last):
  File "/usr/bin/dropbox", line 1360, in <module>
    ret = main(sys.argv)
  File "/usr/bin/dropbox", line 1349, in main
    result = commands[argv[i]](argv[i+1:])
  File "/usr/bin/dropbox", line 1220, in start
    if not start_dropbox():
  File "/usr/bin/dropbox", line 716, in start_dropbox

(I pressed Ctrl-C after it generated the zlib error)

I tried updating zlib and python, installing zlibc,zlib1g,and -dev versions (couldn't find any of these), but alas! Nothing works.

  • tried to purge zlib and re-installing? – Lorenzo Von Matterhorn Dec 13 '12 at 19:18
  • Do you mean with yum reinstall zlib? or do I have to do something like this: serverfault.com/questions/41502/yum-equivalent-of-apt-get-purge – NH. Dec 13 '12 at 21:00
  • the last option you referred is precisely what i meant. – Lorenzo Von Matterhorn Dec 14 '12 at 15:00
  • Tried uninstalling zlib, but it tries to remove yum, which is protected (for good reason: a package manager should never uninstall itself). Simply too many things depend on zlib for me to try your method. – NH. Dec 21 '12 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.